summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Dack <tad@gentoo.org>2003-03-19 13:43:56 +0000
committerTroy Dack <tad@gentoo.org>2003-03-19 13:43:56 +0000
commit537ce06a4b1c9b1d4de8341a3dc93d607253c4f4 (patch)
tree283cdf098b5eaac7d42d59fc3d32b3095e8ccec9 /media-gfx/bootsplash
parentfixed message for moz 1.3 (diff)
downloadhistorical-537ce06a4b1c9b1d4de8341a3dc93d607253c4f4.tar.gz
historical-537ce06a4b1c9b1d4de8341a3dc93d607253c4f4.tar.bz2
historical-537ce06a4b1c9b1d4de8341a3dc93d607253c4f4.zip
Version bump - now with rc scripts
Diffstat (limited to 'media-gfx/bootsplash')
-rw-r--r--media-gfx/bootsplash/ChangeLog9
-rw-r--r--media-gfx/bootsplash/bootsplash-0.4-r1.ebuild114
-rw-r--r--media-gfx/bootsplash/files/bootsplash43
-rw-r--r--media-gfx/bootsplash/files/digest-bootsplash-0.4-r11
4 files changed, 166 insertions, 1 deletions
diff --git a/media-gfx/bootsplash/ChangeLog b/media-gfx/bootsplash/ChangeLog
index 90ca97647f6b..f5ad891e19dc 100644
--- a/media-gfx/bootsplash/ChangeLog
+++ b/media-gfx/bootsplash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/bootsplash
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/ChangeLog,v 1.4 2003/02/12 06:58:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/ChangeLog,v 1.5 2003/03/19 13:43:56 tad Exp $
+
+*bootsplash-0.4-r1 (20 Mar 2003)
+
+ 20 Mar 2003; Troy Dack <tad@gentoo.org> bootsplash-0.4-r1.ebuild,
+ files/bootsplash:
+ Version bump. rc scripts added, installs into ${PN} instead of ${P},
+ config file symlinks now more appropriate.
*bootsplash-0.4-r0 (19 JAN 2003)
diff --git a/media-gfx/bootsplash/bootsplash-0.4-r1.ebuild b/media-gfx/bootsplash/bootsplash-0.4-r1.ebuild
new file mode 100644
index 000000000000..a41f62f2cf86
--- /dev/null
+++ b/media-gfx/bootsplash/bootsplash-0.4-r1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/bootsplash-0.4-r1.ebuild,v 1.1 2003/03/19 13:43:56 tad Exp $
+
+DESCRIPTION="Graphical backgrounds for frame buffer consoles"
+
+HOMEPAGE="http://linux.tkdack.com"
+
+SRC_URI="http://gentoo.tkdack.com/downloads/gentoo/bootsplash-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=""
+
+RDEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ # compile splashutil
+ cd ${S}/splashutil
+ make || die
+}
+
+src_install() {
+
+ exeinto /usr/bin
+ doexe ${S}/splashutil/splash
+
+ # Should install into /usr/share/bootsplash (I hope)
+ insinto /usr/share/${PN}
+ doins ${S}/*.jpg
+ doins ${S}/*.cfg
+
+ # link default config - for boot images
+ dosym ./gentoo-boot-1280x1024.jpg /usr/share/${PN}/bootsplash.jpg
+ dosym ./gentoo-boot-1280x1024.cfg /usr/share/${PN}/bootsplash.cfg
+
+ # link default config - for console images
+ dosym ./gentoo-console-1280x1024.jpg /usr/share/${PN}/consolesplash.jpg
+ dosym ./gentoo-console-1280x1024.cfg /usr/share/${PN}/consolesplash.cfg
+
+ doins ${S}/boot_splash_complete.2.4.19-vanilla.patch
+ doins ${S}/grub.conf.sample
+
+ insinto /etc/init.d
+ doins ${FILESDIR}/bootsplash
+ fperms 755 /etc/init.d/bootsplash
+
+ dodoc README
+ dodoc COPYING
+ dodoc CREDITS
+
+ # generate initial initrd file
+ ${S}/splashutil/splash -s -f ${D}/usr/share/${PN}/bootsplash.cfg > ${D}/usr/share/${PN}/initrd
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/media-gfx/${PN}/${P}.ebuild config\""
+ einfo "to have your kernel sources in /usr/src/linux patched with the"
+ einfo "Framebuffer Bootsplash patches"
+ einfo
+ echo ""
+ ewarn "If you have already patched the kernel then you only need to copy"
+ ewarn "the initrd from /usr/share/${PN}/initrd to /boot"
+ ewarn
+ echo ""
+ einfo
+ einfo "Run:"
+ einfo " rc-update add bootsplash default"
+ einfo " to change the console images after startup"
+ einfo
+}
+
+pkg_config() {
+ ewarn
+ ewarn "Patching the kernel in /usr/src/linux ..."
+ ewarn
+ cd ${ROOT}/usr/src/linux
+ patch -p1 < ${ROOT}/usr/share/${PN}/boot_splash_complete.2.4.19-vanilla.patch || die
+ ewarn
+ ewarn " ... complete."
+ einfo
+ einfo "Your kernel has been patched, rebuild with the following options"
+ einfo "enabled (do not build them as modules!):"
+ einfo " Block Devices ->"
+ einfo " [*] RAM disk support"
+ einfo " [*] Loopback device support"
+ einfo " [*] Initial RAM disk (initrd) support"
+ einfo
+ einfo " Console Drivers ->"
+ einfo " [*] Video mode selection support"
+ einfo " Frame-buffer support ->"
+ einfo " [*] Support for frame buffer devices"
+ einfo " [*] VESA VGA graphics console"
+ einfo " [*] Use splash screen instead of boot logo"
+ einfo
+ einfo "Copy /usr/share/${PN}/initrd to /boot"
+ einfo
+ einfo "Look at \"/usr/share/${PN}/grub.conf.sample\" for an example"
+ einfo "grub.conf file with the appropriate changes to enable the"
+ einfo "framebuffer boot screens"
+ einfo
+ einfo "Ensure you make the appropriate changes to your grub.conf"
+ einfo
+}
diff --git a/media-gfx/bootsplash/files/bootsplash b/media-gfx/bootsplash/files/bootsplash
new file mode 100644
index 000000000000..34dac64f22e0
--- /dev/null
+++ b/media-gfx/bootsplash/files/bootsplash
@@ -0,0 +1,43 @@
+#!/sbin/runscript
+
+depend() {
+ # run after local so that the boot time splash image
+ # is visible for as long as possible
+ after local
+}
+
+start() {
+ # Only do this if the kernel has support
+ if [ -f /proc/splash ]
+ then
+ ebegin "Setting Console frame buffer images"
+
+ # switch to a usable image on all consoles
+ for TTY in `seq 0 5`
+ do
+ /usr/bin/splash -s -u $TTY /usr/share/bootsplash/consolesplash.cfg
+ done
+
+ eend $? "Failed to set frame buffer console images"
+ fi
+}
+
+stop() {
+ # Stop doesn't really stop, it actually changes the image
+ # on vt1 back to the bootsplash image.
+
+ # Only do this if the kernel has support
+ if [ -f /proc/splash ]
+ then
+ ebegin "Setting Console frame buffer images"
+
+ # Put bootsplash image up
+ /usr/bin/splash -s -u 0 /usr/share/bootsplash/bootsplash.cfg
+
+ # switch to vt1 (must be &'d otherwise script hangs)
+ /usr/bin/chvt 1 &
+
+ eend $? "Failed to set frame buffer console images"
+
+ fi
+}
diff --git a/media-gfx/bootsplash/files/digest-bootsplash-0.4-r1 b/media-gfx/bootsplash/files/digest-bootsplash-0.4-r1
new file mode 100644
index 000000000000..ff47ab2133d1
--- /dev/null
+++ b/media-gfx/bootsplash/files/digest-bootsplash-0.4-r1
@@ -0,0 +1 @@
+MD5 2c074a46e2d229863b0df7c5dd9b21a3 bootsplash-0.4.tar.bz2 374032