summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-03-26 12:47:22 +0000
committerDror Levin <spatz@gentoo.org>2010-03-26 12:47:22 +0000
commit098b183127948a1ef1489fed773cfa1ef969e29a (patch)
tree32a659246a2eff86dc3bf86ee6a9017dc65e0877 /media-fonts/urw-fonts/urw-fonts-2.4.9.ebuild
parentDon't inherit unused qt3 eclass (bug #310669) (diff)
downloadhistorical-098b183127948a1ef1489fed773cfa1ef969e29a.tar.gz
historical-098b183127948a1ef1489fed773cfa1ef969e29a.tar.bz2
historical-098b183127948a1ef1489fed773cfa1ef969e29a.zip
Version bump: block media-fonts/gnu-gs-fonts-std and install *.pfm files, wrt bugs 247657 and 256088.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'media-fonts/urw-fonts/urw-fonts-2.4.9.ebuild')
-rw-r--r--media-fonts/urw-fonts/urw-fonts-2.4.9.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-fonts/urw-fonts/urw-fonts-2.4.9.ebuild b/media-fonts/urw-fonts/urw-fonts-2.4.9.ebuild
new file mode 100644
index 000000000000..93b43f64b973
--- /dev/null
+++ b/media-fonts/urw-fonts/urw-fonts-2.4.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/urw-fonts/urw-fonts-2.4.9.ebuild,v 1.1 2010/03/26 12:47:22 spatz Exp $
+
+# At some point URW++ released fonts under GPL license. After that they were took
+# and improved by Valek Filippov and this work was somehow related with AFPL...
+# At least it can be found on their svn server:
+# http://svn.ghostscript.com/ghostscript/trunk/urw-fonts/
+
+# Also, some time ago, sources where published on sf.net:
+# http://sourceforge.net/projects/gs-fonts/files/
+# At this point this package was published on a nuber of other sites
+# (gimp.org/cups.org) and media-fonts/gnu-gs-fonts-std was added to the tree.
+# But nobody use that old releases any mover and everybody syncs with
+# svn.ghostscript.com. The most recent tag there is:
+# http://svn.ghostscript.com/ghostscript/tags/urw-fonts-1.0.7pre44/
+
+# But note that version we have is different from upstream tag. This happened
+# because we started to use redhat versions and followed their versioning. It's
+# hard to say why they use such strange version since they also sync with
+# svn.ghostscript.com. Redhat's ChangeLog states:
+# Tue Jan 8 23:00:00 2008 Than Ngo 2.4-2
+# - update to 1.0.7pre44
+
+inherit eutils rpm font versionator
+
+MY_PV=$(replace_version_separator 2 -)
+
+DESCRIPTION="free good quality fonts gpl'd by URW++"
+HOMEPAGE="http://www.urwpp.de/"
+SRC_URI="mirror://gentoo/${PN}-${MY_PV}.fc13.src.rpm"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x64-solaris ~x86-solaris"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${DEPEND}
+ !media-fonts/gnu-gs-fonts-std"
+
+S=${WORKDIR}
+FONT_S=${S}
+FONT_SUFFIX="afm pfb pfm"
+DOCS="ChangeLog README*"
+
+pkg_postinst() {
+ font_pkg_postinst
+ elog "If you upgraded from ${PN}-2.1-r2 some fonts will look a bit"
+ elog "differently. Take a look at bug #208990 if interested."
+}