summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2005-07-29 01:10:12 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2005-07-29 01:10:12 +0000
commite44fa68c132252d79422801ce9be67179959781e (patch)
treedceac7867c498e22e5a88fc233e05e774859742d /mail-mta/nbsmtp/nbsmtp-1.00.ebuild
parentManual Manifest commit. (diff)
downloadhistorical-e44fa68c132252d79422801ce9be67179959781e.tar.gz
historical-e44fa68c132252d79422801ce9be67179959781e.tar.bz2
historical-e44fa68c132252d79422801ce9be67179959781e.zip
security bump, wrt bug #100274
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'mail-mta/nbsmtp/nbsmtp-1.00.ebuild')
-rw-r--r--mail-mta/nbsmtp/nbsmtp-1.00.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/mail-mta/nbsmtp/nbsmtp-1.00.ebuild b/mail-mta/nbsmtp/nbsmtp-1.00.ebuild
new file mode 100644
index 000000000000..7f735a15bd2d
--- /dev/null
+++ b/mail-mta/nbsmtp/nbsmtp-1.00.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nbsmtp/nbsmtp-1.00.ebuild,v 1.1 2005/07/29 01:10:12 ferdy Exp $
+
+inherit eutils
+
+DESCRIPTION="Extremely simple MTA to get mail off the system to a relayhost"
+SRC_URI="http://www.gentoo-es.org/~ferdy/${P}.tar.bz2"
+#SRC_URI="http://www.it.uc3m.es/~ferdy/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://nbsmtp.ferdyx.org"
+
+SLOT="0"
+KEYWORDS="alpha ~amd64 ~hppa ~ppc ~sparc x86"
+LICENSE="GPL-2"
+IUSE="ssl ipv6 debug"
+
+DEPEND="virtual/libc
+ ssl? ( dev-libs/openssl )"
+
+PROVIDE="virtual/mta"
+
+src_compile() {
+ econf $(use_enable ssl) \
+ $(use_enable debug) \
+ $(use_enable ipv6) || die
+
+ make || die
+}
+
+src_install() {
+ dodir /usr/bin
+ dobin nbsmtp
+ dobin scripts/nbqueue
+ doman nbsmtprc.5 nbsmtp.8
+ dodoc INSTALL DOCS Doxyfile
+}