summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-09-14 14:19:27 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-09-14 14:19:27 +0000
commitfac0470724c482232c1750763ada584d7756fee7 (patch)
treee1923f50d5a71b967b1f17bfb3adf33f5229de5a /mail-filter
parentStable on sparc wrt #62626 take 2, #63948 (diff)
downloadhistorical-fac0470724c482232c1750763ada584d7756fee7.tar.gz
historical-fac0470724c482232c1750763ada584d7756fee7.tar.bz2
historical-fac0470724c482232c1750763ada584d7756fee7.zip
Initial version, closes #19192.
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/spamprobe/ChangeLog11
-rw-r--r--mail-filter/spamprobe/Manifest14
-rw-r--r--mail-filter/spamprobe/files/digest-spamprobe-0.9h2
-rw-r--r--mail-filter/spamprobe/metadata.xml8
-rw-r--r--mail-filter/spamprobe/spamprobe-0.9h.ebuild37
5 files changed, 72 insertions, 0 deletions
diff --git a/mail-filter/spamprobe/ChangeLog b/mail-filter/spamprobe/ChangeLog
new file mode 100644
index 000000000000..952eaa8ce9b1
--- /dev/null
+++ b/mail-filter/spamprobe/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for mail-filter/spamprobe
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamprobe/ChangeLog,v 1.1 2004/09/14 14:19:27 ticho Exp $
+
+*spamprobe-0.9h (14 Sep 2004)
+
+ 14 Sep 2004; Andrej Kacian <ticho@gentoo.org> +metadata.xml,
+ +spamprobe-0.9h.ebuild:
+ Initial version. Closes #19192, ebuild and patch submitted by Alexander
+ Schneider <A.Schneider@magicspace.de>.
+
diff --git a/mail-filter/spamprobe/Manifest b/mail-filter/spamprobe/Manifest
new file mode 100644
index 000000000000..086ac5e02981
--- /dev/null
+++ b/mail-filter/spamprobe/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 882894abe05f9829c47f8dd48e5f5e4c ChangeLog 450
+MD5 3f61d9f697e7b7352880a66d156f26ca metadata.xml 222
+MD5 d71f667a0c1b74b0a418a95580740326 spamprobe-0.9h.ebuild 956
+MD5 22dc99486764b555295bf2a75914f81b files/digest-spamprobe-0.9h 136
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBRv3410xuJSrg3/sRAvlBAJ4oIDBr5EDQXiopJaNvlbad/Tj+7QCfRG9s
+EtC7o0DCifyw6upVQboeJ5Q=
+=53SY
+-----END PGP SIGNATURE-----
diff --git a/mail-filter/spamprobe/files/digest-spamprobe-0.9h b/mail-filter/spamprobe/files/digest-spamprobe-0.9h
new file mode 100644
index 000000000000..5ac6aa118ee6
--- /dev/null
+++ b/mail-filter/spamprobe/files/digest-spamprobe-0.9h
@@ -0,0 +1,2 @@
+MD5 3d36cd1811c860a64f371d318736e808 spamprobe-0.9h.tar.gz 161164
+MD5 e4e75a78e5f16593a559b3aec3b9c384 spamprobe-0.9h-db4.patch.gz 6666
diff --git a/mail-filter/spamprobe/metadata.xml b/mail-filter/spamprobe/metadata.xml
new file mode 100644
index 000000000000..93df6b622623
--- /dev/null
+++ b/mail-filter/spamprobe/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+<maintainer>
+ <email>ticho@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/mail-filter/spamprobe/spamprobe-0.9h.ebuild b/mail-filter/spamprobe/spamprobe-0.9h.ebuild
new file mode 100644
index 000000000000..64b7e2464b46
--- /dev/null
+++ b/mail-filter/spamprobe/spamprobe-0.9h.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamprobe/spamprobe-0.9h.ebuild,v 1.1 2004/09/14 14:19:27 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="Fast, intelligent, automatic spam detector using Paul Graham style Bayesian analysis of word counts in spam and non-spam emails."
+HOMEPAGE="http://spamprobe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/spamprobe/${P}.tar.gz
+ http://dev.gentoo.org/~ticho/portage/spamprobe-0.9h-db4.patch.gz"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="berkdb"
+DEPEND="berkdb? ( >=sys-libs/db-3.2 )
+ sys-devel/autoconf"
+
+src_compile() {
+ unpack ${A}
+ cd ${S}
+
+ # patch for db4 detection and their respective versioned symbols
+ epatch ${WORKDIR}/spamprobe-0.9h-db4.patch
+ autoconf || die
+
+ econf || die
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ dodoc README.txt ChangeLog LICENSE.txt
+
+ einstall || die
+}