summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2005-10-15 08:55:38 +0000
committerTom Martin <slarti@gentoo.org>2005-10-15 08:55:38 +0000
commitf82dd1a93d45b432e0c714c1feba4e3ead692767 (patch)
treee9dfa1f7c058ca16d1f7676a368fe020bce4fe23 /mail-filter
parentFix dependency on x11-libs/gtk+-1.2 (#108147) (diff)
downloadhistorical-f82dd1a93d45b432e0c714c1feba4e3ead692767.tar.gz
historical-f82dd1a93d45b432e0c714c1feba4e3ead692767.tar.bz2
historical-f82dd1a93d45b432e0c714c1feba4e3ead692767.zip
Accidentally removed a needed patch in the purge a few days ago. Resolves bug #108900
Package-Manager: portage-2.0.53_rc5
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/gld/ChangeLog7
-rw-r--r--mail-filter/gld/Manifest9
-rw-r--r--mail-filter/gld/files/gld-1.5.2-mxgrey-fix.patch42
3 files changed, 53 insertions, 5 deletions
diff --git a/mail-filter/gld/ChangeLog b/mail-filter/gld/ChangeLog
index 59965e7f949c..2160a84ca9e8 100644
--- a/mail-filter/gld/ChangeLog
+++ b/mail-filter/gld/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/gld
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/gld/ChangeLog,v 1.25 2005/10/08 08:36:12 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/gld/ChangeLog,v 1.26 2005/10/15 08:55:38 slarti Exp $
+
+ 15 Oct 2005; Tom Martin <slarti@gentoo.org>
+ +files/gld-1.5.2-mxgrey-fix.patch:
+ Accidentally removed a needed patch in the purge a few days ago. Resolves
+ bug #108900.
*gld-1.6 (08 Oct 2005)
diff --git a/mail-filter/gld/Manifest b/mail-filter/gld/Manifest
index 148ea967132b..ad929a870233 100644
--- a/mail-filter/gld/Manifest
+++ b/mail-filter/gld/Manifest
@@ -1,10 +1,11 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 eeddbde7d4f88edd9d2a51e7c0a9b972 ChangeLog 4123
+MD5 2912126307110b5621bb18f47979433e ChangeLog 4298
MD5 96d50f09283d0a87235b23ce0795499e files/Makefile.in 980
MD5 63658f0d53451dbb79e4330fd997bfab files/digest-gld-1.5.2 57
MD5 f91281c6461e403a77e5351e89e398be files/digest-gld-1.6 55
+MD5 135d0ec2459d5f7c3bbeb4cea3381364 files/gld-1.5.2-mxgrey-fix.patch 1702
MD5 4e2b779070d26c7675574fe2420541b8 files/gld.rc 544
MD5 92553e000dd0a23d31042352b053cbdf gld-1.5.2.ebuild 1562
MD5 c82f4d42b6f4cb1d4a64e6d031b018d6 gld-1.6.ebuild 1554
@@ -12,7 +13,7 @@ MD5 8a1c6c5f4c13a4109f6f4198fdd1874b metadata.xml 223
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDR4USCHk4+ZoBpvsRAjtjAJ9xCMi4GdPDt6fz7tvB/BKjYnHK5wCeM3FD
-bNnNviQ5yoO7WLSioTRmOWY=
-=qQHN
+iD8DBQFDUMQgCHk4+ZoBpvsRAroZAJ9GFnBVmxGhUw5ezOv2tU0btvwSdACbBsxa
+9Xrhn9FavCqZ0qfXMsRqHfE=
+=i7Hj
-----END PGP SIGNATURE-----
diff --git a/mail-filter/gld/files/gld-1.5.2-mxgrey-fix.patch b/mail-filter/gld/files/gld-1.5.2-mxgrey-fix.patch
new file mode 100644
index 000000000000..4ec6be79f22e
--- /dev/null
+++ b/mail-filter/gld/files/gld-1.5.2-mxgrey-fix.patch
@@ -0,0 +1,42 @@
+--- gld-1.5.2/greylist.c.orig 2005-08-17 00:44:06.000000000 +0200
++++ gld-1.5.2/greylist.c 2005-08-17 00:40:32.000000000 +0200
+@@ -181,10 +181,29 @@
+
+ if(conf->update==1)
+ {
+- if(conf->lightd==1 && fnotdomain==1)
+- snprintf(query,sizeof(query)-1,"update greylist set last=%d,n=n+1 where ip='%s' and sender='%s' and
+recipient='%s'",ts,ip,osender,orecipient);
+-
+- snprintf(query,sizeof(query)-1,"update greylist set last=%d,n=n+1 where ip='%s' and sender='%s' and
+recipient='%s'",ts,ip,sender,recipient);
++
++ if(ts-n>conf->mini)
++ {
++ if(conf->lightd==1 && fnotdomain==1)
++ snprintf(query,sizeof(query)-1,"update greylist set last=%d,n=n+1 where ip='%s' and sender='%s' and
+recipient='%s'",ts,ip,osender,orecipient);
++
++ snprintf(query,sizeof(query)-1,"update greylist set last=%d,n=n+1 where ip='%s' and sender='%s' and
+recipient='%s'",ts,ip,sender,recipient);
++ }
++ else
++ {
++ //
++ // We have NOT reached the greylist-timeout, so we do NOT increase the message-counter (SQL-field n),
++ // because otherwise we will braek the MXGREY-option.
++ // In fact this means that the THIRD retry will immidiately pass the greylist, as mxgrey checks only for ip and (n>1).
++ //
++ // 2005-08-16 martin@it4linux.de
++ //
++
++ if(conf->lightd==1 && fnotdomain==1)
++ snprintf(query,sizeof(query)-1,"update greylist set last=%d where ip='%s' and sender='%s' and
+recipient='%s'",ts,ip,osender,orecipient);
++
++ snprintf(query,sizeof(query)-1,"update greylist set last=%d where ip='%s' and sender='%s' and
+recipient='%s'",ts,ip,sender,recipient);
++ }
+
+ SQLQuery(query);
+ if(conf->debug==1) printf("%d: Query=(%s)\n",pid,query);