summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTuan Van <langthang@gentoo.org>2004-07-08 20:59:34 +0000
committerTuan Van <langthang@gentoo.org>2004-07-08 20:59:34 +0000
commit54a8be802de4363e11281ab8b4595b647cdfc453 (patch)
treea90c48d981c41dc1984a585a9eed028f369ef5f5 /mail-filter
parentadded filter-flags for freduce-all-givs (bug id 27456) (diff)
downloadhistorical-54a8be802de4363e11281ab8b4595b647cdfc453.tar.gz
historical-54a8be802de4363e11281ab8b4595b647cdfc453.tar.bz2
historical-54a8be802de4363e11281ab8b4595b647cdfc453.zip
version bump, close bug #56422.
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/razor/ChangeLog7
-rw-r--r--mail-filter/razor/Manifest4
-rw-r--r--mail-filter/razor/files/digest-razor-2.611
-rw-r--r--mail-filter/razor/razor-2.61.ebuild69
4 files changed, 79 insertions, 2 deletions
diff --git a/mail-filter/razor/ChangeLog b/mail-filter/razor/ChangeLog
index 02dd2bcfee4d..f9f96eb35016 100644
--- a/mail-filter/razor/ChangeLog
+++ b/mail-filter/razor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/razor
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/razor/ChangeLog,v 1.2 2004/06/24 22:21:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/razor/ChangeLog,v 1.3 2004/07/08 20:59:34 langthang Exp $
+
+*razor-2.61 (08 Jul 2004)
+
+ 08 Jul 2004; Tuan Van<langthang@gentoo.org> +razor-2.61.ebuild:
+ version bump, close bug #56422.
*razor-2.40-r1 (03 Jun 2004)
diff --git a/mail-filter/razor/Manifest b/mail-filter/razor/Manifest
index 2974bfd539be..32a238068a86 100644
--- a/mail-filter/razor/Manifest
+++ b/mail-filter/razor/Manifest
@@ -3,9 +3,10 @@ MD5 0fa323bbbb5f5d60b27805d6097e99d0 razor-2.36.ebuild 2667
MD5 947746be394d4f6eca852901040fab68 razor-2.12.ebuild 656
MD5 57f3a72d406c41cd1d3bff6cd14e25a1 razor-2.40-r1.ebuild 2733
MD5 9a1aef9a38f253160aadac1684e41533 razor-2.14.ebuild 658
+MD5 11cfd6de6a4428832060e48faa56433e razor-2.61.ebuild 2738
MD5 e98fc4703513afce6b72924208970c7f razor-2.36-r1.ebuild 2843
MD5 625ad0838ff3e50a30298c5bfd31d788 razor-2.20.ebuild 2648
-MD5 00145f68243420a95bd4949229ae52de ChangeLog 2539
+MD5 30c73cb4f1f0693a89887166061ec18b ChangeLog 2668
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
MD5 d3e9a49fe82b4c304cafaadb03eedb08 files/razor-taint.patch 2125
MD5 eb86375c84c8a7db9512ca1943fd5a7a files/no-install-razor-agents.patch 292
@@ -16,4 +17,5 @@ MD5 1f098b2f3af4b936a9abf9b3ff35f5d9 files/digest-razor-2.14 68
MD5 e384efda6a508c06a7ce0c4b196d2fb9 files/digest-razor-2.20 68
MD5 86ce0f71341d41a9cf561083b241c9fb files/digest-razor-2.36 68
MD5 24b659c729fbfbf960ca1521df9840da files/digest-razor-2.40 68
+MD5 8fcc1e253bebf4448a7b0f2562ac3609 files/digest-razor-2.61 68
MD5 cf27167873572ac8be99c5195762d630 files/razor_uninstall.patch 1765
diff --git a/mail-filter/razor/files/digest-razor-2.61 b/mail-filter/razor/files/digest-razor-2.61
new file mode 100644
index 000000000000..8f4651acf336
--- /dev/null
+++ b/mail-filter/razor/files/digest-razor-2.61
@@ -0,0 +1 @@
+MD5 8509389ef86594d56a796e556ef83681 razor-agents-2.61.tar.gz 83718
diff --git a/mail-filter/razor/razor-2.61.ebuild b/mail-filter/razor/razor-2.61.ebuild
new file mode 100644
index 000000000000..9de51b21a705
--- /dev/null
+++ b/mail-filter/razor/razor-2.61.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/razor/razor-2.61.ebuild,v 1.1 2004/07/08 20:59:34 langthang Exp $
+
+inherit perl-module eutils
+IUSE=""
+DESCRIPTION="Vipul's Razor is a distributed, collaborative spam detection and filtering network"
+HOMEPAGE="http://razor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/razor/razor-agents-${PV}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+S=${WORKDIR}/razor-agents-${PV}
+
+RDEPEND="dev-lang/perl
+ dev-perl/Net-DNS
+ dev-perl/net-ping
+ dev-perl/Time-HiRes
+ dev-perl/Digest-SHA1
+ dev-perl/URI
+ dev-perl/Digest-Nilsimsa"
+
+
+src_install() {
+ epatch ${FILESDIR}/no-install-razor-agents.patch #31365
+ perl-module_src_install
+}
+
+pkg_postinst() {
+ # insures appropriate symlinks have been created
+ /usr/bin/razor-client
+
+ einfo "Run 'razor-admin -create' to create a default config file in your"
+ einfo "home directory under /home/user/.razor. (Remember to change user to"
+ einfo "your username from root before running razor-admin)"
+ einfo ""
+ einfo "Razor v2 requires reporters to be registered so their reputations can"
+ einfo "be computed over time and they can participate in the revocation"
+ einfo "mechanism. Registration is done with razor-admin -register. It has to be"
+ einfo "manually invoked in either of the following ways:"
+ einfo ""
+ einfo "To register user foo with 's1kret' as password: "
+ einfo ""
+ einfo "razor-admin -register -user=foo -pass=s1kr3t"
+ einfo ""
+ einfo "To register with an email address and have the password assigned:"
+ einfo ""
+ einfo "razor-admin -register -user=foo@bar.com "
+ einfo ""
+ einfo "To have both (random) username and password assgined: "
+ einfo ""
+ einfo "razor-admin -register "
+ einfo ""
+ einfo "razor-admin -register negotiates a registration with the Nomination Server"
+ einfo "and writes the identity information in"
+ einfo "/home/user/.razor/identity-username, or /etc/razor/identity-username"
+ einfo "when invoked as root."
+ einfo ""
+ einfo "You can edit razor-agent.conf to change the defaults. Config options"
+ einfo "and their values are defined in the razor-agent.conf(5) manpage."
+
+ einfo "The next step is to integrate razor-check, razor-report and"
+ einfo "razor-revoke in your mail system. If you are running Razor v1, the"
+ einfo "change will be transparent, new versions of razor agents will overwrite"
+ einfo "the old ones. You would still need to plugin razor-revoke in your MUA,"
+ einfo "since it's a new addition in Razor v2. If you are not running Razor v1,"
+ einfo "refer to manpages of razor-check(1), razor-report(1), and"
+ einfo "razor-revoke(1) for integration instructions."
+}