summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2007-01-27 12:26:43 +0000
committerTom Martin <slarti@gentoo.org>2007-01-27 12:26:43 +0000
commit6d5bbad8a9acf8d1f97547668c23830367644441 (patch)
tree2f610979c2dee3a0309385ba6b771a5196186a38 /mail-client/mail-notification/mail-notification-4.0.ebuild
parentinit script now depends on localmount and bootmisc so that it starts (diff)
downloadhistorical-6d5bbad8a9acf8d1f97547668c23830367644441.tar.gz
historical-6d5bbad8a9acf8d1f97547668c23830367644441.tar.bz2
historical-6d5bbad8a9acf8d1f97547668c23830367644441.zip
Version bump, resolves bug #163752
Package-Manager: portage-2.1.2-r3
Diffstat (limited to 'mail-client/mail-notification/mail-notification-4.0.ebuild')
-rw-r--r--mail-client/mail-notification/mail-notification-4.0.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/mail-client/mail-notification/mail-notification-4.0.ebuild b/mail-client/mail-notification/mail-notification-4.0.ebuild
new file mode 100644
index 000000000000..ded2ba343d67
--- /dev/null
+++ b/mail-client/mail-notification/mail-notification-4.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-4.0.ebuild,v 1.1 2007/01/27 12:26:43 slarti Exp $
+
+inherit eutils gnome2 multilib flag-o-matic
+
+DESCRIPTION="A GNOME trayicon which checks for email. Supports mbox, MH,
+Maildir, IMAP, Sylpheed, POP3, Gmail and Evolution. Authenticates via
+apop, ssl, sasl."
+HOMEPAGE="http://www.nongnu.org/mailnotify/"
+SRC_URI="http://savannah.nongnu.org/download/mailnotify/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+IUSE="imap ipv6 ssl sasl gmail evolution sylpheed mbox maildir pop mozilla"
+
+# gmime is actually optional, but it's used by so much of the package it's
+# pointless making it optional.
+DEPEND=">=x11-libs/gtk+-2.6
+ >=dev-util/gob-2
+ >=gnome-base/gnome-panel-2.6
+ >=gnome-base/eel-2.6
+ >=gnome-base/gconf-2.6
+ >=gnome-base/libgnomeui-2.6
+ >=gnome-base/libglade-2.0
+ >=gnome-base/orbit-2.6
+ >=dev-libs/gmime-2.1
+ dev-perl/XML-Parser
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ evolution? ( >=mail-client/evolution-2.6 )
+ sylpheed? ( virtual/sylpheed )"
+
+pkg_setup() {
+ if use evolution ; then
+ EVO_INSTALLED="$(best_version mail-client/evolution)"
+ EVO_INSTALLED="${EVO_INSTALLED##*/}"
+ EVO_INSTALLED="${EVO_INSTALLED#*-}"
+ EVO_VERSION="$(get_version_component_range 1-2 ${EVO_INSTALLED})"
+ fi
+
+ G2CONF="${G2CONF} $(use_enable ssl)"
+ G2CONF="${G2CONF} $(use_enable sasl)"
+ G2CONF="${G2CONF} $(use_enable ipv6)"
+ # ssl, sasl and ipv6 requires either pop3 or imap, else they will be disabled
+ G2CONF="${G2CONF} $(use_enable imap)"
+ G2CONF="${G2CONF} $(use_enable pop pop3)"
+ G2CONF="${G2CONF} $(use_enable gmail)"
+ G2CONF="${G2CONF} $(use_enable evolution)"
+ G2CONF="${G2CONF} --with-evolution-source-dir=/usr/include/evolution-${EVO_VERSION}"
+ G2CONF="${G2CONF} $(use_enable sylpheed)"
+ G2CONF="${G2CONF} $(use_enable mozilla)"
+}
+
+src_unpack() {
+ S=${WORKDIR}/${PN}-${MY_PV}
+ gnome2_src_unpack
+ gnome2_omf_fix
+
+ sed -i -e 's:gtk-update-icon-cache:true:' ./art/Makefile.in
+}
+
+src_compile() {
+ append-ldflags -Wl,-export-dynamic
+ gnome2_src_compile
+}
+
+src_install() {
+ gnome2_src_install
+ evolution_plugindir="/usr/$(get_libdir)/evolution/${EVO_INSTALLED}/plugins"
+
+ dodoc README NEWS AUTHORS TODO
+}