summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2005-04-10 19:55:26 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2005-04-10 19:55:26 +0000
commit4efb9cfd7f49e48a313ad619412c9f54a230f6e1 (patch)
tree08247098de55565aea799e5bf787839770db73d4 /mail-client/elmo
parentfix dep (diff)
downloadhistorical-4efb9cfd7f49e48a313ad619412c9f54a230f6e1.tar.gz
historical-4efb9cfd7f49e48a313ad619412c9f54a230f6e1.tar.bz2
historical-4efb9cfd7f49e48a313ad619412c9f54a230f6e1.zip
fix bug #88600 by updating src_compile. Reported by: Marek Wiecek <marek.wiecek@gmail.com>
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'mail-client/elmo')
-rw-r--r--mail-client/elmo/ChangeLog6
-rw-r--r--mail-client/elmo/Manifest12
-rw-r--r--mail-client/elmo/elmo-1.3.2-r1.ebuild18
3 files changed, 22 insertions, 14 deletions
diff --git a/mail-client/elmo/ChangeLog b/mail-client/elmo/ChangeLog
index 0e4e8f009f71..d16c98bcf49e 100644
--- a/mail-client/elmo/ChangeLog
+++ b/mail-client/elmo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/elmo
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/elmo/ChangeLog,v 1.13 2005/02/21 17:09:12 citizen428 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/elmo/ChangeLog,v 1.14 2005/04/10 19:55:26 ferdy Exp $
+
+ 10 Apr 2005; Fernando J. Pereda <ferdy@gentoo.org> elmo-1.3.2-r1.ebuild:
+ fix bug #88600 by updating src_compile. Reported by: Marek Wiecek
+ <marek.wiecek@gmail.com>
21 Feb 2005; Michael Kohl <citizen428@gentoo.org> metadata.xml,
elmo-1.3.2-r1.ebuild:
diff --git a/mail-client/elmo/Manifest b/mail-client/elmo/Manifest
index b747b7561727..8cde562baa90 100644
--- a/mail-client/elmo/Manifest
+++ b/mail-client/elmo/Manifest
@@ -1,15 +1,15 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 6087645a70de71055214685bbe00417c elmo-1.3.2-r1.ebuild 1155
-MD5 4a4a292e92cef532ffd6acf2d3b3b0a4 ChangeLog 2326
+MD5 3802c2fd3c8512f5f6b912841584d83d elmo-1.3.2-r1.ebuild 1220
+MD5 56d7c482d6fc4bb87e24fe35cee97e56 ChangeLog 2492
MD5 6f02c7ca1840e1d899cf15f645456f7f metadata.xml 165
MD5 ae516ca333aa45e8df3b9964414f04ff files/digest-elmo-1.3.2-r1 62
MD5 030a20e67a5eb594c5aa4216043285d0 files/configure.in.patch 1991
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
+Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCGhXH/UDVUK2NELYRAhfVAKC6Cb/dszPrKMKP/FJwsYRace0OHgCgv0Tr
-0Q1u7C+n8k+TMJbTESygg8M=
-=a6oP
+iD8DBQFCWYTOViELBEf1JB0RApD3AJ403p0sEpvBWB0vhPhJTeO+22NzxgCfdJlj
+AUZCEED8NYwcapNAhmOLvzY=
+=GRHd
-----END PGP SIGNATURE-----
diff --git a/mail-client/elmo/elmo-1.3.2-r1.ebuild b/mail-client/elmo/elmo-1.3.2-r1.ebuild
index ef144cc83dc6..4bb49f758487 100644
--- a/mail-client/elmo/elmo-1.3.2-r1.ebuild
+++ b/mail-client/elmo/elmo-1.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/elmo/elmo-1.3.2-r1.ebuild,v 1.4 2005/02/21 17:09:12 citizen428 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/elmo/elmo-1.3.2-r1.ebuild,v 1.5 2005/04/10 19:55:26 ferdy Exp $
inherit eutils
@@ -18,17 +18,21 @@ RDEPEND="ssl? ( dev-libs/openssl )
nls? ( sys-devel/gettext )
crypt? ( >=app-crypt/gpgme-0.9.0 )"
-
src_compile() {
local myconf
- epatch ${FILESDIR}/configure.in.patch
+ epatch ${FILESDIR}/configure.in.patch || die "epatch failed"
+
+ ebegin "Rebuilding configure"
+ autoconf || die "autoconf failed"
+ eend $?
+
+ use ssl && myconf="--with-openssl=/usr"
- myconf="${myconf} `use_enable nls`"
- myconf="${myconf} `use_with ssl openssl`"
- myconf="${myconf} `use_with crypt gpgme`"
+ econf ${myconf} \
+ $(use_enable nls) \
+ $(use_with crypt gpgme) || die "econf failed"
- econf ${myconf} || die "econf failed"
emake || die "emake failed"
}