summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2008-12-22 14:46:26 +0000
committerChristian Faulhammer <fauli@gentoo.org>2008-12-22 14:46:26 +0000
commit2f0a0eb9af4121c7eeb689f6c46704f747872f9b (patch)
treeb96e8d492562a48d7b360a153b4389b36167870f /mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.7.ebuild
parentMask new gnustep-base release until matching gorm is available (diff)
downloadhistorical-2f0a0eb9af4121c7eeb689f6c46704f747872f9b.tar.gz
historical-2f0a0eb9af4121c7eeb689f6c46704f747872f9b.tar.bz2
historical-2f0a0eb9af4121c7eeb689f6c46704f747872f9b.zip
version bump
Package-Manager: portage-2.1.4.5
Diffstat (limited to 'mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.7.ebuild')
-rw-r--r--mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.7.ebuild b/mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.7.ebuild
new file mode 100644
index 000000000000..540f7ad134bd
--- /dev/null
+++ b/mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.7.ebuild,v 1.1 2008/12/22 14:39:25 fauli Exp $
+
+inherit eutils
+
+MY_P="${P#claws-mail-}"
+
+DESCRIPTION="Plugin for Claws to report spam to various places"
+HOMEPAGE="http://www.claws-mail.org/"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND=">=mail-client/claws-mail-3.6.1
+ >=net-misc/curl-7.9.7"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # kill useless files
+ rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}