summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-11-14 11:02:32 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-11-14 11:02:32 +0000
commit8ea831634f2556957750ed4a597b6d57ba3f4183 (patch)
tree888106412fdbdbdaae9db8c0e6de4f4d5485aca9 /kde-frameworks/knotifications/knotifications-5.4.0.ebuild
parentRemoved, package now lives in net-misc (diff)
downloadhistorical-8ea831634f2556957750ed4a597b6d57ba3f4183.tar.gz
historical-8ea831634f2556957750ed4a597b6d57ba3f4183.tar.bz2
historical-8ea831634f2556957750ed4a597b6d57ba3f4183.zip
Version bump.
Package-Manager: portage-2.2.14/cvs/Linux x86_64
Diffstat (limited to 'kde-frameworks/knotifications/knotifications-5.4.0.ebuild')
-rw-r--r--kde-frameworks/knotifications/knotifications-5.4.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/knotifications/knotifications-5.4.0.ebuild b/kde-frameworks/knotifications/knotifications-5.4.0.ebuild
new file mode 100644
index 000000000000..fa6216993768
--- /dev/null
+++ b/kde-frameworks/knotifications/knotifications-5.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/knotifications/knotifications-5.4.0.ebuild,v 1.1 2014/11/14 11:01:35 mrueg Exp $
+
+EAPI=5
+
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Framework for notifying the user of an event, including feedback and persistant events"
+LICENSE="LGPL-2.1+"
+KEYWORDS=" ~amd64"
+IUSE="dbus nls X"
+
+RDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwindowsystem)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/phonon[qt5]
+ dbus? ( dev-libs/libdbusmenu-qt[qt5] )
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+"
+DEPEND="${RDEPEND}
+ nls? ( dev-qt/linguist-tools:5 )
+ X? ( x11-proto/xproto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X X11)
+ $(cmake-utils_use_find_package dbus DBusMenuQt5)
+ )
+
+ kde5_src_configure
+}