summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-10-20 11:01:46 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-10-20 11:01:46 +0000
commitc92a9b1b4072f5bfe24a7b10601cd4fa994fecc2 (patch)
tree3d56fbef3fc2fded2205928476c3cf98dc15eeb0 /kde-base
parentPunted ftpusers as ftpbase supplies it (diff)
downloadhistorical-c92a9b1b4072f5bfe24a7b10601cd4fa994fecc2.tar.gz
historical-c92a9b1b4072f5bfe24a7b10601cd4fa994fecc2.tar.bz2
historical-c92a9b1b4072f5bfe24a7b10601cd4fa994fecc2.zip
Added patch to compile kcheckpass fine on PIC architectures when using --enable-final. See bug #107218.
Package-Manager: portage-2.0.53_rc5
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kcheckpass/ChangeLog7
-rw-r--r--kde-base/kcheckpass/files/kcheckpass-pie-final.patch20
-rw-r--r--kde-base/kcheckpass/kcheckpass-3.5.0_beta2.ebuild6
-rw-r--r--kde-base/kdebase/ChangeLog7
-rw-r--r--kde-base/kdebase/files/kcheckpass-pie-final.patch20
-rw-r--r--kde-base/kdebase/kdebase-3.5.0_beta2.ebuild6
6 files changed, 62 insertions, 4 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index ae568afbcb13..7e109265a26e 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.20 2005/10/15 11:08:40 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.21 2005/10/20 11:01:46 flameeyes Exp $
+
+ 20 Oct 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kcheckpass-pie-final.patch, kcheckpass-3.5.0_beta2.ebuild:
+ Added patch to compile kcheckpass fine on PIC architectures when using
+ --enable-final. See bug #107218.
*kcheckpass-3.5.0_beta2 (14 Oct 2005)
diff --git a/kde-base/kcheckpass/files/kcheckpass-pie-final.patch b/kde-base/kcheckpass/files/kcheckpass-pie-final.patch
new file mode 100644
index 000000000000..3ae34a4d6724
--- /dev/null
+++ b/kde-base/kcheckpass/files/kcheckpass-pie-final.patch
@@ -0,0 +1,20 @@
+Index: Makefile.am
+===================================================================
+--- kcheckpass/Makefile.am (revision 472230)
++++ kcheckpass/Makefile.am (revision 472231)
+@@ -2,14 +2,13 @@
+ ## written by Christian Esken
+ ##
+
+-INCLUDES= $(all_includes)
++INCLUDES= $(KDE_USE_FPIE) $(all_includes)
+
+ bin_PROGRAMS = kcheckpass
+
+ kcheckpass_SOURCES = kcheckpass.c \
+ checkpass_etcpasswd.c checkpass_pam.c checkpass_shadow.c \
+ checkpass_osfc2passwd.c checkpass_aix.c
+-kcheckpass_CFLAGS = $(KDE_USE_FPIE)
+ kcheckpass_LDADD = -lkdefakes $(PASSWDLIBS) $(LIBSOCKET)
+ kcheckpass_LDFLAGS = $(KDE_USE_PIE) $(all_libraries)
+
diff --git a/kde-base/kcheckpass/kcheckpass-3.5.0_beta2.ebuild b/kde-base/kcheckpass/kcheckpass-3.5.0_beta2.ebuild
index a963da350985..b3b0214ed3d6 100644
--- a/kde-base/kcheckpass/kcheckpass-3.5.0_beta2.ebuild
+++ b/kde-base/kcheckpass/kcheckpass-3.5.0_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-3.5.0_beta2.ebuild,v 1.1 2005/10/14 18:41:50 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-3.5.0_beta2.ebuild,v 1.2 2005/10/20 11:01:46 flameeyes Exp $
KMNAME=kdebase
MAXKDEVER=$PV
@@ -12,3 +12,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="pam"
DEPEND="pam? ( kde-base/kdebase-pam ) !pam? ( sys-apps/shadow )"
+# Fixes problem with PIE and kcheckpass with --enable-final on PIC plaforms
+# Already applied for 3.5 RC.
+PATCHES="${FILESDIR}/${PN}-pie-final.patch"
+
diff --git a/kde-base/kdebase/ChangeLog b/kde-base/kdebase/ChangeLog
index c26339a7e616..85bd38d536a3 100644
--- a/kde-base/kdebase/ChangeLog
+++ b/kde-base/kdebase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdebase
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.225 2005/10/19 13:48:05 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.226 2005/10/20 10:59:45 flameeyes Exp $
+
+ 20 Oct 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kcheckpass-pie-final.patch, kdebase-3.5.0_beta2.ebuild:
+ Added patch to compile kcheckpass fine on PIC architectures when using
+ --enable-final. See bug #107218.
*kdebase-3.4.3-r1 (19 Oct 2005)
diff --git a/kde-base/kdebase/files/kcheckpass-pie-final.patch b/kde-base/kdebase/files/kcheckpass-pie-final.patch
new file mode 100644
index 000000000000..3ae34a4d6724
--- /dev/null
+++ b/kde-base/kdebase/files/kcheckpass-pie-final.patch
@@ -0,0 +1,20 @@
+Index: Makefile.am
+===================================================================
+--- kcheckpass/Makefile.am (revision 472230)
++++ kcheckpass/Makefile.am (revision 472231)
+@@ -2,14 +2,13 @@
+ ## written by Christian Esken
+ ##
+
+-INCLUDES= $(all_includes)
++INCLUDES= $(KDE_USE_FPIE) $(all_includes)
+
+ bin_PROGRAMS = kcheckpass
+
+ kcheckpass_SOURCES = kcheckpass.c \
+ checkpass_etcpasswd.c checkpass_pam.c checkpass_shadow.c \
+ checkpass_osfc2passwd.c checkpass_aix.c
+-kcheckpass_CFLAGS = $(KDE_USE_FPIE)
+ kcheckpass_LDADD = -lkdefakes $(PASSWDLIBS) $(LIBSOCKET)
+ kcheckpass_LDFLAGS = $(KDE_USE_PIE) $(all_libraries)
+
diff --git a/kde-base/kdebase/kdebase-3.5.0_beta2.ebuild b/kde-base/kdebase/kdebase-3.5.0_beta2.ebuild
index bd9eac8a1d57..47cd21ca49df 100644
--- a/kde-base/kdebase/kdebase-3.5.0_beta2.ebuild
+++ b/kde-base/kdebase/kdebase-3.5.0_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.5.0_beta2.ebuild,v 1.2 2005/10/19 13:48:05 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.5.0_beta2.ebuild,v 1.3 2005/10/20 10:59:45 flameeyes Exp $
inherit kde-dist eutils
@@ -43,6 +43,10 @@ src_unpack() {
# Avoid using imake (kde bug 114466).
epatch "${FILESDIR}/kdebase-3.5.0_beta2-noimake.patch"
+ # Fixes problem with PIE and kcheckpass with --enable-final on PIC plaforms
+ # Already applied for 3.5 RC.
+ epatch "${FILESDIR}/kcheckpass-pie-final.patch"
+
# For the noimake patch.
make -f admin/Makefile.common || die
}