summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2003-08-05 13:01:42 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2003-08-05 13:01:42 +0000
commit74a69e7b365ee4fc33155d555442c4a74c98a244 (patch)
tree5ac882a00806962f42fb5d84113e8315e2636c45 /kde-base
parentFix the horizontal scrollbar issue in khtml (diff)
downloadhistorical-74a69e7b365ee4fc33155d555442c4a74c98a244.tar.gz
historical-74a69e7b365ee4fc33155d555442c4a74c98a244.tar.bz2
historical-74a69e7b365ee4fc33155d555442c4a74c98a244.zip
Fix the horizontal scrollbar issue in khtml
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdelibs/Manifest6
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.1.3-r11
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.1.3-render_root.patch20
-rw-r--r--kde-base/kdelibs/kdelibs-3.1.3-r1.ebuild76
4 files changed, 100 insertions, 3 deletions
diff --git a/kde-base/kdelibs/Manifest b/kde-base/kdelibs/Manifest
index 15f149e5ea8c..1ee21c138c16 100644
--- a/kde-base/kdelibs/Manifest
+++ b/kde-base/kdelibs/Manifest
@@ -1,5 +1,5 @@
-MD5 99dcecd948327d155f65d8cc14b9db11 ChangeLog 14560
-MD5 d3f1eef85d6ad7e32f53b3b600e5b9ba kdelibs-3.1.3-r1.ebuild 2487
+MD5 428129734c14bf10a3f0051c465bb334 ChangeLog 14763
+MD5 ddb6c82d86d0d23d9ac6e7d64bf46b00 kdelibs-3.1.3-r1.ebuild 2502
MD5 ecb842ef67a00a4a3348c92a784cc3b7 kdelibs-2.2.2a-r2.ebuild 2570
MD5 8a21daa4525f5d8edef9d9be0d4a3354 kdelibs-3.0.4-r1.ebuild 2303
MD5 e907b234e307a34e574f3225b3f7d17b kdelibs-3.0.5b-r1.ebuild 1994
@@ -25,7 +25,7 @@ MD5 c087405ca3581f6493850d59c98dcefa files/kdelibs-3.1.2-khtml.patch 1486
MD5 0783bde2d3df61818e8563b3a445742b files/digest-kdelibs-3.1.3-r1 68
MD5 acd90863c0847e230aa37f3943d58176 files/kdelibs-3.0.5b-libxml2-2.5.2.diff 703
MD5 41d30ba8cf8d36ad3caebeedb1ddfd0e files/kdelibs-3.1.3-kjs-alphaev6-gcc3-workaround.patch 477
-MD5 63986fe45e7c35c7b863d17a77504610 files/kdelibs-3.1.3-render_root.patch 1731
+MD5 36a366fd1a948f28712eab93b5be7e52 files/kdelibs-3.1.3-render_root.patch 896
MD5 41d30ba8cf8d36ad3caebeedb1ddfd0e files/kdelibs-3.1.1a-kjs-alphaev6-gcc3-workaround.patch 477
MD5 adfd3d17be1f45423f07f22cd0c73427 files/digest-kdelibs-3.1.2 68
MD5 41d30ba8cf8d36ad3caebeedb1ddfd0e files/kdelibs-3.1.2-kjs-alphaev6-gcc3-workaround.patch 477
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.1.3-r1 b/kde-base/kdelibs/files/digest-kdelibs-3.1.3-r1
new file mode 100644
index 000000000000..70252e2d27cf
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.1.3-r1
@@ -0,0 +1 @@
+MD5 0069e199dd69f27f20afbd5b64449725 kdelibs-3.1.3.tar.bz2 10533062
diff --git a/kde-base/kdelibs/files/kdelibs-3.1.3-render_root.patch b/kde-base/kdelibs/files/kdelibs-3.1.3-render_root.patch
new file mode 100644
index 000000000000..5dd45e95efae
--- /dev/null
+++ b/kde-base/kdelibs/files/kdelibs-3.1.3-render_root.patch
@@ -0,0 +1,20 @@
+--- khtml/rendering/render_root.cpp.orig 16 Jul 2003 00:13:32 -0000 1.116.2.3
++++ khtml/rendering/render_root.cpp 2 Aug 2003 21:28:49 -0000 1.116.2.4
+@@ -118,7 +118,7 @@ void RenderRoot::layout()
+ #endif
+ if (!m_printingMode) {
+ QSize s = m_view->viewportSize(m_view->contentsWidth(),
+- 0);
++ m_view->contentsHeight());
+ m_width = s.width();
+ m_height = s.height();
+ }
+@@ -132,7 +132,7 @@ void RenderRoot::layout()
+ if (!m_printingMode) {
+ m_view->resizeContents(docWidth(), docHeight());
+ QSize s = m_view->viewportSize(m_view->contentsWidth(),
+- m_view->contentsHeight());
++ 0);
+ setWidth( m_viewportWidth = s.width() );
+ setHeight( m_viewportHeight = s.height() );
+ }
diff --git a/kde-base/kdelibs/kdelibs-3.1.3-r1.ebuild b/kde-base/kdelibs/kdelibs-3.1.3-r1.ebuild
new file mode 100644
index 000000000000..bf963dbdee3c
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.1.3-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.1.3-r1.ebuild,v 1.1 2003/08/05 13:01:34 pauldv Exp $
+inherit kde
+#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
+
+IUSE="alsa cups ipv6 ssl"
+DESCRIPTION="KDE libraries needed by all kde programs"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+HOMEPAGE="http//www.kde.org/"
+SLOT="3.1"
+LICENSE="GPL-2 LGPL-2"
+SRC_URI="mirror://kde/stable/$PV/src/${P}.tar.bz2"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
+# so we recreate the entire DEPEND from scratch.
+DEPEND=""
+RDEPEND="doc? ( ~app-doc/kdelibs-apidocs-$PV )"
+newdepend "dev-lang/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libxslt-1.0.7
+ >=dev-libs/libpcre-3.5
+ >=dev-libs/libxml2-2.4.10
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 >=media-sound/alsa-driver-0.5.9 )
+ cups? ( >=net-print/cups-1.1.14 )
+ >=media-libs/tiff-3.5.5
+ app-admin/fam-oss
+ app-text/ghostscript
+ media-libs/libart_lgpl
+ sys-devel/gettext
+ ~kde-base/arts-1.1.3"
+
+newdepend "/autotools"
+
+RDEPEND="$RDEPEND
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python
+ >=sys-apps/portage-2.0.36" # for #7359
+
+myconf="$myconf --with-distribution=Gentoo --enable-libfam --enable-dnotify"
+use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+
+use x86 && myconf="$myconf --enable-fast-malloc=full"
+
+qtver-from-kdever ${PV}
+need-qt $selected_version
+
+set-kdedir $PV
+
+src_unpack() {
+ kde_src_unpack
+ kde_sandbox_patch ${S}/kio/misc/kpac
+ use alpha && cd ${S} && epatch ${FILESDIR}/${P}-kjs-alphaev6-gcc3-workaround.patch
+ cd ${S} && epatch ${FILESDIR}/${P}-render_root.patch
+}
+
+src_install() {
+ kde_src_install
+ dohtml *.html
+
+ # kdelibs-apidocs is provided by kdelibs-apidocs ebuild, kdelibs ebuild
+ # shouldn't install anything into kdelibs-apidocs (bug #15102)
+ rm -r ${D}/$KDEDIR/share/doc/HTML/en/kdelibs-apidocs
+}
+
+pkg_postinst() {
+ einfo "If you have kde 3.0.x installed, please upgrade to kdeils-3.0.5a-r2 and kdebase-3.0.5a-r1.
+ If they don't have your arch's keywords, edit /etc/env.d/65kdelibs-3.0.*, remove the KDEDIRS=
+ line and env-update."
+}