summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-05-03 20:08:11 +0000
committerJohannes Huber <johu@gentoo.org>2012-05-03 20:08:11 +0000
commit5927f5c54422bdd7e485d04e5a5f7d18663ee66f (patch)
tree23ce069db9e32e9974c6b94cfa73af651ada1e7f /kde-base/superkaramba
parentMask >ghc-7 on Tiger and Leopard (diff)
downloadhistorical-5927f5c54422bdd7e485d04e5a5f7d18663ee66f.tar.gz
historical-5927f5c54422bdd7e485d04e5a5f7d18663ee66f.tar.bz2
historical-5927f5c54422bdd7e485d04e5a5f7d18663ee66f.zip
Version bump KDE SC 4.8.3
Package-Manager: portage-2.2.0_alpha101/cvs/Linux x86_64
Diffstat (limited to 'kde-base/superkaramba')
-rw-r--r--kde-base/superkaramba/ChangeLog7
-rw-r--r--kde-base/superkaramba/superkaramba-4.8.3.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/superkaramba/ChangeLog b/kde-base/superkaramba/ChangeLog
index 01dc81d7a948..14f0c9c579bf 100644
--- a/kde-base/superkaramba/ChangeLog
+++ b/kde-base/superkaramba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/superkaramba
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.196 2012/04/18 20:34:55 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.197 2012/05/03 20:07:57 johu Exp $
+
+*superkaramba-4.8.3 (03 May 2012)
+
+ 03 May 2012; Johannes Huber <johu@gentoo.org> +superkaramba-4.8.3.ebuild:
+ Version bump KDE SC 4.8.3
18 Apr 2012; Markus Meier <maekke@gentoo.org> superkaramba-4.8.1.ebuild:
x86 stable, bug #409403
diff --git a/kde-base/superkaramba/superkaramba-4.8.3.ebuild b/kde-base/superkaramba/superkaramba-4.8.3.ebuild
new file mode 100644
index 000000000000..2d311d40b41e
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.8.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.8.3.ebuild,v 1.1 2012/05/03 20:07:57 johu Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2"
+KDE_SCM="git"
+inherit python kde4-base
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+DEPEND="
+ media-libs/qimageblitz
+ python? ( $(add_kdebase_dep pykde4) )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython) )
+"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ )
+
+ kde4-base_src_configure
+}