summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-12-11 18:52:41 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-12-11 18:52:41 +0000
commit351f7dda3f62817dd3747226a48fb58b92f8e510 (patch)
treed44f25d056ad34656ac0a5ac45ee7fa316af0df4 /kde-base/oxygen-icons
parentAdd 3.0 documentation (diff)
downloadhistorical-351f7dda3f62817dd3747226a48fb58b92f8e510.tar.gz
historical-351f7dda3f62817dd3747226a48fb58b92f8e510.tar.bz2
historical-351f7dda3f62817dd3747226a48fb58b92f8e510.zip
[kde-base] Add long waiting KDE SC 4.7.4
Package-Manager: portage-2.2.0_alpha79/cvs/Linux x86_64
Diffstat (limited to 'kde-base/oxygen-icons')
-rw-r--r--kde-base/oxygen-icons/ChangeLog7
-rw-r--r--kde-base/oxygen-icons/oxygen-icons-4.7.4.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/kde-base/oxygen-icons/ChangeLog b/kde-base/oxygen-icons/ChangeLog
index eedb89b0e29c..962893b60495 100644
--- a/kde-base/oxygen-icons/ChangeLog
+++ b/kde-base/oxygen-icons/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/oxygen-icons
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/oxygen-icons/ChangeLog,v 1.86 2011/12/07 23:07:40 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/oxygen-icons/ChangeLog,v 1.87 2011/12/11 18:52:21 alexxy Exp $
+
+*oxygen-icons-4.7.4 (11 Dec 2011)
+
+ 11 Dec 2011; Alexey Shvetsov <alexxy@gentoo.org> +oxygen-icons-4.7.4.ebuild:
+ Version bump KDE SC 4.7.4
07 Dec 2011; Andreas K. Huettel <dilfridge@gentoo.org>
-oxygen-icons-4.7.2.ebuild:
diff --git a/kde-base/oxygen-icons/oxygen-icons-4.7.4.ebuild b/kde-base/oxygen-icons/oxygen-icons-4.7.4.ebuild
new file mode 100644
index 000000000000..625673dabf8e
--- /dev/null
+++ b/kde-base/oxygen-icons/oxygen-icons-4.7.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/oxygen-icons/oxygen-icons-4.7.4.ebuild,v 1.1 2011/12/11 18:52:21 alexxy Exp $
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]]; then
+ KMNAME="kdesupport"
+else
+ # Upstream does not ship releases properly so we dont want all versions
+ MY_PV="4.7.4"
+ MY_P="${PN}-${MY_PV}"
+fi
+KDE_REQUIRED="never"
+inherit kde4-base
+
+DESCRIPTION="Oxygen SVG icon theme."
+HOMEPAGE="http://www.oxygen-icons.org/"
+# Note that the upstream tarball is .bz2, ours is .xz -- if upstream
+# changes its compression format to .xz, we will need to change the
+# filename of one of the tarballs
+[[ ${PV} == *9999 ]] || \
+SRC_URI="
+ !bindist? ( http://dev.gentoo.org/~alexxy/distfiles/${MY_P}.tar.xz )
+ bindist? ( ${SRC_URI//${PV}/${MY_PV}} )
+"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="aqua bindist"
+
+DEPEND="
+ !bindist? ( app-arch/xz-utils )
+"
+RDEPEND=""
+
+[[ ${PV} == *9999 ]] || S=${WORKDIR}/${MY_P}