summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-05 12:40:14 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-05 12:40:14 +0000
commit811a7154483119ea9831d8fdfe78190d5f146f40 (patch)
tree1769dd645f3ad12960ee724355664d952ee01460 /kde-base/nsplugins
parentStable on sparc wrt #165335 (diff)
downloadhistorical-811a7154483119ea9831d8fdfe78190d5f146f40.tar.gz
historical-811a7154483119ea9831d8fdfe78190d5f146f40.tar.bz2
historical-811a7154483119ea9831d8fdfe78190d5f146f40.zip
Remove unneeded patches.
Package-Manager: portage-2.1.2-r7
Diffstat (limited to 'kde-base/nsplugins')
-rw-r--r--kde-base/nsplugins/ChangeLog6
-rw-r--r--kde-base/nsplugins/files/nsplugins-3.5.3-applet-redirects.patch67
2 files changed, 5 insertions, 68 deletions
diff --git a/kde-base/nsplugins/ChangeLog b/kde-base/nsplugins/ChangeLog
index 9d4d35941d08..a92410707256 100644
--- a/kde-base/nsplugins/ChangeLog
+++ b/kde-base/nsplugins/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/nsplugins
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/nsplugins/ChangeLog,v 1.75 2007/02/04 03:17:07 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/nsplugins/ChangeLog,v 1.76 2007/02/05 12:12:44 flameeyes Exp $
+
+ 05 Feb 2007; Diego Pettenò <flameeyes@gentoo.org>
+ -files/nsplugins-3.5.3-applet-redirects.patch:
+ Remove unneeded patches.
04 Feb 2007; Diego Pettenò <flameeyes@gentoo.org>
-nsplugins-3.5.2.ebuild:
diff --git a/kde-base/nsplugins/files/nsplugins-3.5.3-applet-redirects.patch b/kde-base/nsplugins/files/nsplugins-3.5.3-applet-redirects.patch
deleted file mode 100644
index 5f8ded2292e0..000000000000
--- a/kde-base/nsplugins/files/nsplugins-3.5.3-applet-redirects.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-Index: nsplugins/viewer/nsplugin.cpp
-===================================================================
---- nsplugins/viewer/nsplugin.cpp (revision 565997)
-+++ nsplugins/viewer/nsplugin.cpp (revision 565998)
-@@ -1602,6 +1602,12 @@
- return true;
- }
-
-+void NSPluginStreamBase::updateURL( const KURL& newURL )
-+{
-+ _url = newURL;
-+ free(const_cast<char*>(_stream->url));
-+ _stream->url = strdup(_url.url().ascii());
-+}
-
- int NSPluginStreamBase::process( const QByteArray &data, int start )
- {
-@@ -1824,6 +1830,8 @@
- SLOT(totalSize(KIO::Job *, KIO::filesize_t)));
- connect(_job, SIGNAL(mimetype(KIO::Job *, const QString &)),
- SLOT(mimetype(KIO::Job *, const QString &)));
-+ connect(_job, SIGNAL(redirection(KIO::Job *, const KURL&)),
-+ SLOT(redirection(KIO::Job *, const KURL&)));
- }
-
- return false;
-@@ -1847,6 +1855,8 @@
- SLOT(totalSize(KIO::Job *, KIO::filesize_t)));
- connect(_job, SIGNAL(mimetype(KIO::Job *, const QString &)),
- SLOT(mimetype(KIO::Job *, const QString &)));
-+ connect(_job, SIGNAL(redirection(KIO::Job *, const KURL&)),
-+ SLOT(redirection(KIO::Job *, const KURL&)));
- }
-
- return false;
-@@ -1863,6 +1873,11 @@
- }
- }
-
-+void NSPluginStream::redirection(KIO::Job * /*job*/, const KURL& url)
-+{
-+ updateURL( url );
-+}
-+
- void NSPluginStream::totalSize(KIO::Job * job, KIO::filesize_t size)
- {
- kdDebug(1431) << "NSPluginStream::totalSize - job=" << (void*)job << " size=" << KIO::number(size) << endl;
-Index: nsplugins/viewer/nsplugin.h
-===================================================================
---- nsplugins/viewer/nsplugin.h (revision 565997)
-+++ nsplugins/viewer/nsplugin.h (revision 565998)
-@@ -85,6 +85,7 @@
- bool create( const QString& url, const QString& mimeType, void *notify, bool forceNotify = false );
- int tries() { return _tries; }
- void inform( );
-+ void updateURL( const KURL& newURL );
-
- class NSPluginInstance *_instance;
- uint16 _streamType;
-@@ -126,6 +127,7 @@
- void totalSize(KIO::Job *job, KIO::filesize_t size);
- void mimetype(KIO::Job * job, const QString &mimeType);
- void result(KIO::Job *job);
-+ void redirection(KIO::Job *job, const KURL& url);
- void resume();
-
- protected: