summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-02 17:08:23 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-02 17:08:23 +0000
commitb14044a81f315ea1bdcc459acac04287e63fdb9f (patch)
tree9411d90a290c8925a33920b61401c1e762dceabd /kde-base/kxkb
parentmedia-libs/libopendaap stable on ppc. (diff)
downloadhistorical-b14044a81f315ea1bdcc459acac04287e63fdb9f.tar.gz
historical-b14044a81f315ea1bdcc459acac04287e63fdb9f.tar.bz2
historical-b14044a81f315ea1bdcc459acac04287e63fdb9f.zip
Adding a bit more of a patch to allow selection of alt-intl variant (by accepting the '-' in layout and variant name).
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'kde-base/kxkb')
-rw-r--r--kde-base/kxkb/ChangeLog9
-rw-r--r--kde-base/kxkb/files/kxkb-3.5.0-modularxkb.patch17
2 files changed, 21 insertions, 5 deletions
diff --git a/kde-base/kxkb/ChangeLog b/kde-base/kxkb/ChangeLog
index ff34815ba7bc..fbd86ed7c6db 100644
--- a/kde-base/kxkb/ChangeLog
+++ b/kde-base/kxkb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kxkb
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kxkb/ChangeLog,v 1.37 2005/12/19 19:07:01 flameeyes Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kxkb/ChangeLog,v 1.38 2006/01/02 17:05:50 flameeyes Exp $
+
+ 02 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ files/kxkb-3.5.0-modularxkb.patch:
+ Adding a bit more of a patch to allow selection of alt-intl variant (by
+ accepting the '-' in layout and variant name).
19 Dec 2005; Diego Pettenò <flameeyes@gentoo.org> kxkb-3.5.0.ebuild:
Add runtime dependencies on xkbdata and setxkb for modularx.
diff --git a/kde-base/kxkb/files/kxkb-3.5.0-modularxkb.patch b/kde-base/kxkb/files/kxkb-3.5.0-modularxkb.patch
index f19bfd25f825..47eea8ee7efa 100644
--- a/kde-base/kxkb/files/kxkb-3.5.0-modularxkb.patch
+++ b/kde-base/kxkb/files/kxkb-3.5.0-modularxkb.patch
@@ -1,7 +1,7 @@
-Index: kxkb/rules.cpp
+Index: kdebase-3.5.0/kxkb/rules.cpp
===================================================================
---- kxkb/rules.cpp (revision 487566)
-+++ kxkb/rules.cpp (working copy)
+--- kdebase-3.5.0.orig/kxkb/rules.cpp
++++ kdebase-3.5.0/kxkb/rules.cpp
@@ -17,13 +17,13 @@
#include "rules.h"
@@ -18,3 +18,14 @@ Index: kxkb/rules.cpp
if( QDir(X11DirList[ii]).exists() ) {
X11_DIR = X11DirList[ii];
break;
+@@ -292,8 +292,8 @@ KeyRules::getVariants(const QString& lay
+
+ void KeyRules::parseVariants(const QStringList& vars, QDict<char>& variants, bool chkVars)
+ {
+- static const char* LAYOUT_PATTERN = "[a-z0-9_]*";
+- static const char* VARIANT_PATTERN = "\\([a-z0-9_]*\\)";
++ static const char* LAYOUT_PATTERN = "[a-z0-9_-]*";
++ static const char* VARIANT_PATTERN = "\\([a-z0-9_-]*\\)";
+ for (QStringList::ConstIterator it = vars.begin(); it != vars.end(); ++it)
+ {
+ QString varLine = (*it).stripWhiteSpace();