summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-09-01 16:32:24 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-09-01 16:32:24 +0000
commit0941f8f8b9ab158f571c295f3e1a4db8e2117481 (patch)
tree395111f62c037d6bc60c879297b61c7bbb00ccc4 /kde-base/ktux/ktux-4.3.1.ebuild
parentstable sparc, bug 282379 (diff)
downloadhistorical-0941f8f8b9ab158f571c295f3e1a4db8e2117481.tar.gz
historical-0941f8f8b9ab158f571c295f3e1a4db8e2117481.tar.bz2
historical-0941f8f8b9ab158f571c295f3e1a4db8e2117481.zip
Version bump KDE 4.3.1
Package-Manager: portage-2.2_rc38/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/ktux/ktux-4.3.1.ebuild')
-rw-r--r--kde-base/ktux/ktux-4.3.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-base/ktux/ktux-4.3.1.ebuild b/kde-base/ktux/ktux-4.3.1.ebuild
new file mode 100644
index 000000000000..273168236dde
--- /dev/null
+++ b/kde-base/ktux/ktux-4.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ktux/ktux-4.3.1.ebuild,v 1.1 2009/09/01 16:06:38 tampakrap Exp $
+
+EAPI="2"
+
+KMNAME="kdetoys"
+inherit kde4-meta
+
+DESCRIPTION="KDE: screensaver featuring the Space-Faring Tux"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug"
+
+# libkworkspace - only as a stub to provide KDE4Workspace config
+DEPEND="
+ >=kde-base/kscreensaver-${PV}:${SLOT}[kdeprefix=]
+ >=kde-base/libkworkspace-${PV}:${SLOT}[kdeprefix=]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e's/${KDE4WORKSPACE_KSCREENSAVER_LIBRARY}/kscreensaver/' \
+ "${PN}"/CMakeLists.txt || die "Failed to patch CMakeLists.txt"
+
+ kde4-meta_src_prepare
+}