summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-05-03 20:08:11 +0000
committerJohannes Huber <johu@gentoo.org>2012-05-03 20:08:11 +0000
commit5927f5c54422bdd7e485d04e5a5f7d18663ee66f (patch)
tree23ce069db9e32e9974c6b94cfa73af651ada1e7f /kde-base/ksystemlog/ksystemlog-4.8.3.ebuild
parentMask >ghc-7 on Tiger and Leopard (diff)
downloadhistorical-5927f5c54422bdd7e485d04e5a5f7d18663ee66f.tar.gz
historical-5927f5c54422bdd7e485d04e5a5f7d18663ee66f.tar.bz2
historical-5927f5c54422bdd7e485d04e5a5f7d18663ee66f.zip
Version bump KDE SC 4.8.3
Package-Manager: portage-2.2.0_alpha101/cvs/Linux x86_64
Diffstat (limited to 'kde-base/ksystemlog/ksystemlog-4.8.3.ebuild')
-rw-r--r--kde-base/ksystemlog/ksystemlog-4.8.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-base/ksystemlog/ksystemlog-4.8.3.ebuild b/kde-base/ksystemlog/ksystemlog-4.8.3.ebuild
new file mode 100644
index 000000000000..f9147b84a3b0
--- /dev/null
+++ b/kde-base/ksystemlog/ksystemlog-4.8.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ksystemlog-4.8.3.ebuild,v 1.1 2012/05/03 20:07:54 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeadmin"
+
+VIRTUALX_REQUIRED=test
+inherit kde4-meta
+
+DESCRIPTION="KDE system log viewer"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug test"
+
+RESTRICT=test
+# bug 378101
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i ksystemlog/tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}