summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
commit171699a002ecd434bf376ad233dbe24d18eb2eb6 (patch)
tree6f899a3828a1e37ab8065f27a01b95c12cdc03e0 /kde-base/ksquares
parentbump to the TeX Live 2011 version (diff)
downloadhistorical-171699a002ecd434bf376ad233dbe24d18eb2eb6.tar.gz
historical-171699a002ecd434bf376ad233dbe24d18eb2eb6.tar.bz2
historical-171699a002ecd434bf376ad233dbe24d18eb2eb6.zip
[kde-base] Version bump KDE SC 4.7.0
Package-Manager: portage-2.2.0_alpha47/cvs/Linux x86_64
Diffstat (limited to 'kde-base/ksquares')
-rw-r--r--kde-base/ksquares/ChangeLog7
-rw-r--r--kde-base/ksquares/ksquares-4.7.0.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/kde-base/ksquares/ChangeLog b/kde-base/ksquares/ChangeLog
index 395777d8d5dd..d81a7eef7c1a 100644
--- a/kde-base/ksquares/ChangeLog
+++ b/kde-base/ksquares/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksquares
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksquares/ChangeLog,v 1.87 2011/07/09 15:13:58 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksquares/ChangeLog,v 1.88 2011/07/27 14:04:29 alexxy Exp $
+
+*ksquares-4.7.0 (27 Jul 2011)
+
+ 27 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +ksquares-4.7.0.ebuild:
+ Version bump KDE SC 4.7.0
*ksquares-4.6.5 (09 Jul 2011)
diff --git a/kde-base/ksquares/ksquares-4.7.0.ebuild b/kde-base/ksquares/ksquares-4.7.0.ebuild
new file mode 100644
index 000000000000..6c0eae1a2dd0
--- /dev/null
+++ b/kde-base/ksquares/ksquares-4.7.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksquares/ksquares-4.7.0.ebuild,v 1.1 2011/07/27 14:04:29 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdegames"
+inherit games-ggz kde4-meta
+
+DESCRIPTION="KSquares is an implementation of the game squares for KDE4"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+src_prepare() {
+ # cmake is doing this really weird
+ sed -i \
+ -e "s:register_ggz_module:#register_ggz_module:g" \
+ ${PN}/src/CMakeLists.txt || die "ggz removal failed"
+
+ kde4-meta_src_prepare
+}
+
+src_install() {
+ kde4-meta_src_install
+ # and also we have to prepare the ggz dir
+ insinto "${GGZ_MODDIR}"
+ newins ${PN}/src/module.dsc ${P}.dsc
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ games-ggz_pkg_postinst
+}
+
+pkg_postrm() {
+ kde4-meta_pkg_postrm
+ games-ggz_pkg_postrm
+}