summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-01-18 00:14:04 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-01-18 00:14:04 +0000
commit5d9daf0a2d11d00fd9d77b63e091258c832488f0 (patch)
tree613da11d032d50d60b6df1e38a1f483dbee327f8 /kde-base/kopete
parentAdded KDE 4.0.0's konsole. (diff)
downloadhistorical-5d9daf0a2d11d00fd9d77b63e091258c832488f0.tar.gz
historical-5d9daf0a2d11d00fd9d77b63e091258c832488f0.tar.bz2
historical-5d9daf0a2d11d00fd9d77b63e091258c832488f0.zip
Added KDE 4.0.0's kopete.
Package-Manager: portage-2.1.4
Diffstat (limited to 'kde-base/kopete')
-rw-r--r--kde-base/kopete/ChangeLog7
-rw-r--r--kde-base/kopete/files/digest-kopete-4.0.03
-rw-r--r--kde-base/kopete/kopete-4.0.0.ebuild99
3 files changed, 108 insertions, 1 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index f18384911e1a..45096bdeb7e7 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.127 2008/01/13 17:49:47 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.128 2008/01/18 00:14:03 ingmar Exp $
+
+*kopete-4.0.0 (18 Jan 2008)
+
+ 18 Jan 2008; Ingmar Vanhassel <ingmar@gentoo.org> +kopete-4.0.0.ebuild:
+ Added KDE 4.0.0's kopete.
13 Jan 2008; Wulf C. Krueger <philantrop@gentoo.org> kopete-3.5.8.ebuild:
Made kopete depend on qca-1.0* and qca-tls-1.0*. Fixes bug 180599.
diff --git a/kde-base/kopete/files/digest-kopete-4.0.0 b/kde-base/kopete/files/digest-kopete-4.0.0
new file mode 100644
index 000000000000..d00c395e3461
--- /dev/null
+++ b/kde-base/kopete/files/digest-kopete-4.0.0
@@ -0,0 +1,3 @@
+MD5 f362bd34b589800845abfb99589d4cfc kdenetwork-4.0.0.tar.bz2 6349575
+RMD160 a7c95df6f257585c67eca04f7e6d3d433149814c kdenetwork-4.0.0.tar.bz2 6349575
+SHA256 c18008e0247d942750b69a47d13abed538e535d53ce626e124a655f0457e7113 kdenetwork-4.0.0.tar.bz2 6349575
diff --git a/kde-base/kopete/kopete-4.0.0.ebuild b/kde-base/kopete/kopete-4.0.0.ebuild
new file mode 100644
index 000000000000..c7595e58506c
--- /dev/null
+++ b/kde-base/kopete/kopete-4.0.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-4.0.0.ebuild,v 1.1 2008/01/18 00:14:03 ingmar Exp $
+
+EAPI="1"
+
+KMNAME=kdenetwork
+inherit kde4-meta
+
+DESCRIPTION="KDE multi-protocol IM client"
+KEYWORDS="~amd64 ~x86"
+IUSE="+addbookmarks +alias +autoreplace +contactnotes debug gadu groupwise
++highlight +history htmlhandbook +jabber latex +msn +nowlistening oscar
++privacy qq sms +statistics testbed +texteffect +translator
++urlpicpreview +webpresence winpopup yahoo"
+# telepathy is broken.
+
+#IUSE="irc jingle meanwhile messenger oscar ppp qq rdesktop ssl"
+
+# plugins: latex, history, contactnotes, translator, nowlistening, texteffect, highlight, alias
+# addbookmarks, privacy, urlpicpreview, (sqlite?) statistics, (&& xml2 xslt) webpresence
+# protocols: msn, oscar, yahoo, qq, irc (disabled?), winpopup, (ssl?) gadu, sms, messenger,
+# msn, (&& qca2 idn) jabber, (qca2?) groupwise, testbed, (decibel?) telepathy
+
+# meanwhile hasn't been ported to kde4 yet
+# jingle and irc are disabled in the package
+# messenger is the new msn support protocol (it's not ready yet)
+
+# Tests are KDE-ish.
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libpcre
+ kde-base/qimageblitz
+ x11-libs/libXScrnSaver
+ gadu? ( dev-libs/openssl )
+ groupwise? ( app-crypt/qca:2 )
+ jabber? ( net-dns/libidn app-crypt/qca:2 )
+ statistics? ( dev-db/sqlite:3 )
+ webpresence? ( dev-libs/libxml2 dev-libs/libxslt )"
+# telepathy? ( net-libs/decibel )
+
+DEPEND="${RDEPEND}
+ x11-proto/scrnsaverproto"
+
+src_compile() {
+ # Xmms isn't in portage, thus forcefully disabled.
+ # $(cmake-utils_use_with messenger)
+ mycmakeargs="${mycmakeargs}
+ -DWITH_Xmms=OFF
+ -DWITH_telepathy=OFF
+ $(cmake-utils_use_with addbookmarks)
+ $(cmake-utils_use_with alias)
+ $(cmake-utils_use_with autoreplace)
+ $(cmake-utils_use_with contactnotes)
+ $(cmake-utils_use_with gadu OPENSSL)
+ $(cmake-utils_use_with groupwise)
+ $(cmake-utils_use_with groupwise QCA2)
+ $(cmake-utils_use_with highlight)
+ $(cmake-utils_use_with history)
+ $(cmake-utils_use_with jabber IDN)
+ $(cmake-utils_use_with jabber QCA2)
+ $(cmake-utils_use_with latex)
+ $(cmake-utils_use_with msn)
+ $(cmake-utils_use_with nowlistening)
+ $(cmake-utils_use_with oscar)
+ $(cmake-utils_use_with privacy)
+ $(cmake-utils_use_with qq)
+ $(cmake-utils_use_with sms)
+ $(cmake-utils_use_with statistics Sqlite)
+ $(cmake-utils_use_with statistics)
+ $(cmake-utils_use_with testbed)
+ $(cmake-utils_use_with texteffect)
+ $(cmake-utils_use_with translator)
+ $(cmake-utils_use_with urlpicpreview)
+ $(cmake-utils_use_with webpresence LibXml2)
+ $(cmake-utils_use_with webpresence LibXslt)
+ $(cmake-utils_use_with webpresence)
+ $(cmake-utils_use_with winpopup)
+ $(cmake-utils_use_with yahoo)"
+
+# $(cmake-utils_use_with telepathy)
+# $(cmake-utils_use_with telepathy Decibel)
+
+ kde4-meta_src_compile
+}
+
+pkg_postinst() {
+# if use telepathy; then
+# elog "To use kopete telepathy plugins, you need to start gabble first:"
+# elog "GABBLE_PERSIST=1 telepathy-gabble &"
+# elog "export TELEPATHY_DATA_PATH=/usr/share/telepathy/managers/"
+# fi
+ if use jabber; then
+ echo
+ elog "In order to use ssl in jabber, messenger and irc you'll need to have qca-ossl"
+ echo
+ fi
+}