summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:16:40 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:16:40 +0000
commit69684548245f6c7113ab42a2dc9cb6f28b76f178 (patch)
tree73417a3da65e3d25d44abbb7456ef18c5a5bea7e /kde-base/kontact
parent[kde-base/attica] Add missing metadata (diff)
downloadhistorical-69684548245f6c7113ab42a2dc9cb6f28b76f178.tar.gz
historical-69684548245f6c7113ab42a2dc9cb6f28b76f178.tar.bz2
historical-69684548245f6c7113ab42a2dc9cb6f28b76f178.zip
[kde-base/kontact] Version bump to KDE SC 4.4.0
Package-Manager: portage-2.2_rc62/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kontact')
-rw-r--r--kde-base/kontact/ChangeLog8
-rw-r--r--kde-base/kontact/files/fix-broken-gpgme-cmake-guard.diff32
-rw-r--r--kde-base/kontact/kontact-4.4.0.ebuild57
3 files changed, 96 insertions, 1 deletions
diff --git a/kde-base/kontact/ChangeLog b/kde-base/kontact/ChangeLog
index c6c6f8207a83..284c10f40069 100644
--- a/kde-base/kontact/ChangeLog
+++ b/kde-base/kontact/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kontact
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/ChangeLog,v 1.144 2010/01/25 16:32:27 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/ChangeLog,v 1.145 2010/02/09 00:16:33 alexxy Exp $
+
+*kontact-4.4.0 (08 Feb 2010)
+
+ 08 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +kontact-4.4.0.ebuild,
+ +files/fix-broken-gpgme-cmake-guard.diff:
+ Version bump to KDE SC 4.4.0
*kontact-4.3.5 (25 Jan 2010)
diff --git a/kde-base/kontact/files/fix-broken-gpgme-cmake-guard.diff b/kde-base/kontact/files/fix-broken-gpgme-cmake-guard.diff
new file mode 100644
index 000000000000..90aee5f5ce69
--- /dev/null
+++ b/kde-base/kontact/files/fix-broken-gpgme-cmake-guard.diff
@@ -0,0 +1,32 @@
+Index: kontact/plugins/CMakeLists.txt
+===================================================================
+--- kontact/plugins/CMakeLists.txt (revision 1073383)
++++ kontact/plugins/CMakeLists.txt (working copy)
+@@ -1,18 +1,16 @@
+ remove_definitions(-DKDE_DEFAULT_DEBUG_AREA=5600) #remove kontact debug area
+ add_definitions(-DKDE_DEFAULT_DEBUG_AREA=5602)
+
+-if(QGPGME_FOUND)
+- if(BUILD_kmail)
+- add_subdirectory( kmail )
+- endif(BUILD_kmail)
+- if (BUILD_kmail AND BUILD_korganizer)
+- add_subdirectory( korganizer )
+- endif (BUILD_kmail AND BUILD_korganizer)
+- add_subdirectory( summary )
+- add_subdirectory( specialdates )
++if(BUILD_kmail)
++ add_subdirectory( kmail )
++endif(BUILD_kmail)
++if (BUILD_kmail AND BUILD_korganizer)
++ add_subdirectory( korganizer )
++endif (BUILD_kmail AND BUILD_korganizer)
++add_subdirectory( summary )
++add_subdirectory( specialdates )
+ #re-enable planner for 4.2 if we have people who want to develop it
+- add_subdirectory( planner )
+-endif(QGPGME_FOUND)
++add_subdirectory( planner )
+ if (BUILD_knotes)
+ add_subdirectory( knotes )
+ endif (BUILD_knotes)
diff --git a/kde-base/kontact/kontact-4.4.0.ebuild b/kde-base/kontact/kontact-4.4.0.ebuild
new file mode 100644
index 000000000000..6876b540913e
--- /dev/null
+++ b/kde-base/kontact/kontact-4.4.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/kontact-4.4.0.ebuild,v 1.1 2010/02/09 00:16:33 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KDE personal information manager"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep libkdepim)
+"
+RDEPEND="${DEPEND}"
+
+KMLOADLIBS="libkdepim"
+KMSAVELIBS="true"
+
+# We remove plugins that are related to external kdepim programs. This way
+# kontact doesn't have to depend on all programs it has plugins for.
+# kcontactmanager gone from kdesvn
+#
+# xml targets from kmail/ are being uncommented by kde4-meta.eclass
+KMEXTRACTONLY="
+ kmail/
+ kontact/plugins/akregator/
+ kontact/plugins/kaddressbook/
+ kontact/plugins/kjots/
+ kontact/plugins/kmail/
+ kontact/plugins/knode/
+ kontact/plugins/knotes/
+ kontact/plugins/korganizer/
+ kontact/plugins/ktimetracker/
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA+="
+ doc/kontact-admin/
+ "
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/fix-broken-gpgme-cmake-guard.diff"
+
+ # Need to patch it this way
+ kde4-meta_src_prepare
+}