summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2008-09-14 00:00:42 +0000
committerCarsten Lohrke <carlo@gentoo.org>2008-09-14 00:00:42 +0000
commitb974b6ef740bd72ca318243730adf05a46a3ac13 (patch)
tree83960462b16e9bb431666835e4b3d90f67f1c45c /kde-base/klaptopdaemon/klaptopdaemon-3.5.10.ebuild
parentVersion bump and include patch to support Audacious 1.5. (diff)
downloadhistorical-b974b6ef740bd72ca318243730adf05a46a3ac13.tar.gz
historical-b974b6ef740bd72ca318243730adf05a46a3ac13.tar.bz2
historical-b974b6ef740bd72ca318243730adf05a46a3ac13.zip
Version bump.
Diffstat (limited to 'kde-base/klaptopdaemon/klaptopdaemon-3.5.10.ebuild')
-rw-r--r--kde-base/klaptopdaemon/klaptopdaemon-3.5.10.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/kde-base/klaptopdaemon/klaptopdaemon-3.5.10.ebuild b/kde-base/klaptopdaemon/klaptopdaemon-3.5.10.ebuild
new file mode 100644
index 000000000000..2114a32708c8
--- /dev/null
+++ b/kde-base/klaptopdaemon/klaptopdaemon-3.5.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/klaptopdaemon/klaptopdaemon-3.5.10.ebuild,v 1.1 2008/09/13 23:58:49 carlo Exp $
+
+KMNAME=kdeutils
+EAPI="1"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdeutils-3.5-patchset-02.tar.bz2"
+
+DESCRIPTION="KLaptopdaemon - KDE battery monitoring and management for laptops."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdehiddenvisibility xscreensaver"
+
+RDEPEND="x11-libs/libXtst
+ xscreensaver? ( x11-libs/libXScrnSaver )"
+
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+EPATCH_EXCLUDE="klaptopdaemon-3.5-suspend2+xsession-errors.diff
+ klaptopdaemon-3.5-lock-and-hibernate.diff"
+
+src_compile() {
+ myconf="${myconf} $(use_with xscreensaver)"
+
+ kde_src_compile
+}