summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-16 22:05:24 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-16 22:05:24 +0000
commitc42e804d3105165738b33c98b2f7e5e90712b754 (patch)
tree4fb1de5b454bbf0fd16011900d4696d8729e075d /kde-base/kicker/kicker-3.5.6.ebuild
parentStable on amd64 per bug #161640 (diff)
downloadhistorical-c42e804d3105165738b33c98b2f7e5e90712b754.tar.gz
historical-c42e804d3105165738b33c98b2f7e5e90712b754.tar.bz2
historical-c42e804d3105165738b33c98b2f7e5e90712b754.zip
Bump to 3.5.6 (prerelease).
Package-Manager: portage-2.1.2
Diffstat (limited to 'kde-base/kicker/kicker-3.5.6.ebuild')
-rw-r--r--kde-base/kicker/kicker-3.5.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-base/kicker/kicker-3.5.6.ebuild b/kde-base/kicker/kicker-3.5.6.ebuild
new file mode 100644
index 000000000000..4297a4a1273b
--- /dev/null
+++ b/kde-base/kicker/kicker-3.5.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kicker/kicker-3.5.6.ebuild,v 1.1 2007/01/16 20:39:17 flameeyes Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdebase-3.5-patchset-03.tar.bz2"
+
+DESCRIPTION="Kicker is the KDE application starter panel and is also capable of some useful applets and extensions."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdehiddenvisibility xcomposite"
+
+RDEPEND="
+$(deprange $PV $MAXKDEVER kde-base/libkonq)
+$(deprange $PV $MAXKDEVER kde-base/kdebase-data)
+ || ( (
+ x11-libs/libXau
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXtst
+ ) <virtual/x11-7 )
+ xcomposite? ( || ( x11-libs/libXcomposite <x11-base/xorg-x11-7 ) )"
+
+DEPEND="${RDEPEND}
+ xcomposite? ( || ( x11-proto/compositeproto <x11-base/xorg-x11-7 ) )"
+
+KMCOPYLIB="libkonq libkonq"
+KMEXTRACTONLY="libkonq
+ kdm/kfrontend/themer/"
+KMCOMPILEONLY="kdmlib/"
+
+src_compile() {
+ myconf="$myconf $(use_with xcomposite composite)"
+ kde-meta_src_compile
+}