summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-03-11 00:07:10 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-03-11 00:07:10 +0000
commit7d230fcd1e93cc9b3925ccc230cc470effb56dea (patch)
tree357908cfce1aa7466aefe4803c167bfd1cd69d63 /kde-base/kfax
parentAdded sys-apps/findutils to RDEPEND since find/xargs are used by the bootmisc... (diff)
downloadhistorical-7d230fcd1e93cc9b3925ccc230cc470effb56dea.tar.gz
historical-7d230fcd1e93cc9b3925ccc230cc470effb56dea.tar.bz2
historical-7d230fcd1e93cc9b3925ccc230cc470effb56dea.zip
Version bump to KDE 4.0.2.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/kfax')
-rw-r--r--kde-base/kfax/ChangeLog7
-rw-r--r--kde-base/kfax/kfax-4.0.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/kde-base/kfax/ChangeLog b/kde-base/kfax/ChangeLog
index bfa9c6ed2fc1..be064499c139 100644
--- a/kde-base/kfax/ChangeLog
+++ b/kde-base/kfax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kfax
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kfax/ChangeLog,v 1.79 2008/03/04 05:10:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kfax/ChangeLog,v 1.80 2008/03/11 00:03:32 philantrop Exp $
+
+*kfax-4.0.1 (10 Mar 2008)
+
+ 10 Mar 2008; Wulf C. Krueger <philantrop@gentoo.org> +kfax-4.0.1.ebuild:
+ Version bump to KDE 4.0.2
04 Mar 2008; Jeroen Roovers <jer@gentoo.org> kfax-3.5.8.ebuild,
kfax-3.5.9.ebuild:
diff --git a/kde-base/kfax/kfax-4.0.1.ebuild b/kde-base/kfax/kfax-4.0.1.ebuild
new file mode 100644
index 000000000000..d290fd78cab4
--- /dev/null
+++ b/kde-base/kfax/kfax-4.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kfax/kfax-4.0.1.ebuild,v 1.1 2008/03/11 00:03:32 philantrop Exp $
+
+EAPI="1"
+
+NEED_KDE="${PV}"
+inherit kde4-base
+
+# old versions of kfax are versioned like kde (up to 3.5.8). this is newer and
+# hence we need a higher version (4.0.1).
+MY_PV="3.3.6"
+DESCRIPTION="KDE G3/G4 fax viewer"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2 LGPL-2"
+SRC_URI="mirror://kde/stable/${PV}/src/extragear/${PN}-${MY_PV}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="kde-4"
+IUSE=""
+
+LANGS="af ar be bg br ca cs cy da de el en_GB eo es et eu fa fi fr ga gl he hr
+hu is it ja km ko lt lv mk ms nb nds ne nl nn oc pa pl pt pt_BR ro ru se sk sl
+sr sv ta tg th tr uk vi wa xh zh_CN zh_HK zh_TW"
+
+for _X in ${LANGS}; do
+ IUSE="${IUSE} linguas_${_X}"
+done
+
+PREFIX="${KDEDIR}"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ comment_all_add_subdirectory po/ || die "sed to remove all linguas failed."
+
+ local _X
+ for _X in ${LANGS}; do
+ if use linguas_${X}; then
+ sed -i -e "/add_subdirectory(\s*${X}\s*)\s*$/ s/^#DONOTCOMPILE //" \
+ po/CMakeLists.txt || die "sed to uncomment ${lang} failed."
+ fi
+ done
+
+ kde4-base_src_compile
+}