summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2008-06-05 21:35:27 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2008-06-05 21:35:27 +0000
commitf7ffab6760fb31c30344fdaf711f9f41feab138c (patch)
tree0429b93de9f3ee5506a13ea17f74d3f50b426967 /kde-base/kdepimlibs
parentAdded the KDE 4.0.5 version of kdepasswd. (diff)
downloadhistorical-f7ffab6760fb31c30344fdaf711f9f41feab138c.tar.gz
historical-f7ffab6760fb31c30344fdaf711f9f41feab138c.tar.bz2
historical-f7ffab6760fb31c30344fdaf711f9f41feab138c.zip
Added the KDE 4.0.5 version of kdepimlibs.
Package-Manager: portage-2.2_pre7/cvs/Linux 2.6.25-gentoo-r4 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog8
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.0.5.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index 50e56b0f8d41..0b59354910de 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.10 2008/05/15 23:23:00 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.11 2008/06/05 21:35:27 keytoaster Exp $
+
+*kdepimlibs-4.0.5 (05 Jun 2008)
+
+ 05 Jun 2008; Tobias Heinlein <keytoaster@gentoo.org>
+ +kdepimlibs-4.0.5.ebuild:
+ Added the KDE 4.0.5 version of kdepimlibs.
*kdepimlibs-4.0.4 (15 May 2008)
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.0.5.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.0.5.ebuild
new file mode 100644
index 000000000000..019c51cc6e67
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.0.5.ebuild,v 1.1 2008/06/05 21:35:27 keytoaster Exp $
+
+EAPI="1"
+
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook ldap sasl"
+LICENSE="GPL-2 LGPL-2"
+
+# Tests last checked in 4.0.3. Over 50% fails. A lot hang.
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/gpgme-1.1.6
+ dev-libs/boost
+ dev-libs/libgpg-error
+ ldap? ( >=net-nds/openldap-2 )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with ldap Ldap)
+ $(cmake-utils_use_with sasl Sasl2)"
+ kde4-base_src_compile
+}