summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-09-06 02:10:06 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-09-06 02:10:06 +0000
commit385ff8b2910e50bae3c5e4b04aab109640ba9bd0 (patch)
treed9033ecafa524717a40d45159d963ed5151a493d /kde-base/kdepimlibs
parentAutomated update of use.local.desc (diff)
downloadhistorical-385ff8b2910e50bae3c5e4b04aab109640ba9bd0.tar.gz
historical-385ff8b2910e50bae3c5e4b04aab109640ba9bd0.tar.bz2
historical-385ff8b2910e50bae3c5e4b04aab109640ba9bd0.zip
Version bump KDE SC 4.5.1
Package-Manager: portage-2.2_rc75/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog8
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.5.1.ebuild71
2 files changed, 78 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index 90a3847c7789..f7da2a8546c9 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.83 2010/08/10 13:08:07 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.84 2010/09/06 00:13:08 tampakrap Exp $
+
+*kdepimlibs-4.5.1 (06 Sep 2010)
+
+ 06 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kdepimlibs-4.5.1.ebuild:
+ Version bump
10 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org>
-files/kdepimlibs-4.4.0-sieve.patch:
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.5.1.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.5.1.ebuild
new file mode 100644
index 000000000000..16c23189b903
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.5.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.5.1.ebuild,v 1.1 2010/09/06 00:13:08 tampakrap Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK=1
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS=""
+LICENSE="LGPL-2.1"
+IUSE="debug ldap semantic-desktop"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/gpgme-1.1.6
+ >=dev-libs/boost-1.35.0-r5
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.43
+ dev-libs/cyrus-sasl
+ semantic-desktop? (
+ >=app-office/akonadi-server-1.3.60
+ $(add_kdebase_dep kdelibs 'semantic-desktop')
+ media-sound/phonon
+ x11-misc/shared-mime-info
+ )
+ ldap? ( net-nds/openldap )
+"
+RDEPEND="${DEPEND}"
+
+# libakonadi-kcal moved here from akonadi in 4.3.86
+add_blocker akonadi '<4.3.86'
+# @since 4.3 - libkholidays is in kdepimlibs now
+add_blocker libkholidays
+# @since 4.4 - kontactinterfaces is in kdepimlibs now
+add_blocker kontactinterfaces
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ # Disable hardcoded checks
+ sed -r -e '/find_package\((Akonadi|SharedDesktopOntologies|Soprano|Nepomuk)/{/macro_optional_/!s/find/macro_optional_&/}' \
+ -e '/macro_log_feature\((Akonadi|SHAREDDESKTOPONTOLOGIES|Soprano|Nepomuk)_FOUND/s/ TRUE / FALSE /' \
+ -e '/add_subdirectory\((akonadi|mailtransport)/{/macro_optional_/!s/add/macro_optional_&/}' \
+ -i CMakeLists.txt || die
+ if ! use semantic-desktop; then
+ sed -e '/include(SopranoAddOntology)/s/^/#DISABLED /' \
+ -i CMakeLists.txt || die
+ # More reliable than -DBUILD_akonadi=OFF
+ rm -r akonadi mailtransport || die
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_with ldap)
+ $(cmake-utils_use_with semantic-desktop Akonadi)
+ $(cmake-utils_use_with semantic-desktop SharedDesktopOntologies)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-base_src_configure
+}