summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2003-12-03 23:17:53 +0000
committerCaleb Tennis <caleb@gentoo.org>2003-12-03 23:17:53 +0000
commita74dc2a75639795319de573072eb36cb0903dd7d (patch)
treeef4636ba183f5899863ef866d1cbbd4b51266549 /kde-base/kdeadmin
parentnew beta version (diff)
downloadhistorical-a74dc2a75639795319de573072eb36cb0903dd7d.tar.gz
historical-a74dc2a75639795319de573072eb36cb0903dd7d.tar.bz2
historical-a74dc2a75639795319de573072eb36cb0903dd7d.zip
new beta version
Diffstat (limited to 'kde-base/kdeadmin')
-rw-r--r--kde-base/kdeadmin/Manifest4
-rw-r--r--kde-base/kdeadmin/files/digest-kdeadmin-3.2.0_beta21
-rw-r--r--kde-base/kdeadmin/kdeadmin-3.2.0_beta2.ebuild36
3 files changed, 39 insertions, 2 deletions
diff --git a/kde-base/kdeadmin/Manifest b/kde-base/kdeadmin/Manifest
index 17463cdea10c..ba7fa5482225 100644
--- a/kde-base/kdeadmin/Manifest
+++ b/kde-base/kdeadmin/Manifest
@@ -1,10 +1,10 @@
MD5 be064c51dc99d15eac923e8eebd2e84e kdeadmin-3.1.4.ebuild 1363
MD5 b2bdd0b01b78395be6bcb5d5af6a4d4b kdeadmin-3.0.5b.ebuild 791
MD5 4b814e1828f9b286c828e94bec18aca7 kdeadmin-3.2.0_beta1.ebuild 1243
-MD5 cab04e54a264d7ddd0d8aace0f55ff3e ChangeLog 7321
+MD5 18b629a78f73d38f3b6b33032a31772f ChangeLog 7450
MD5 14889ab75f97d76e58b0c1154e7683a9 metadata.xml 161
MD5 97025c29f78ad5392ab528a179326531 kdeadmin-3.0.4.ebuild 528
-MD5 4b814e1828f9b286c828e94bec18aca7 kdeadmin-3.2.0_beta2.ebuild 1243
+MD5 56cc9a783eebcbc3825fa7d70779b73f kdeadmin-3.2.0_beta2.ebuild 1243
MD5 a6705bd443a458d94e5cb40b6d8d17cd kdeadmin-3.1.2.ebuild 1599
MD5 cfd611aaf828a1fb0407ac3a55ce0167 files/digest-kdeadmin-3.2.0_beta1 69
MD5 8e7d18ab7de7bfdfaa653d7bf258c101 files/digest-kdeadmin-3.2.0_beta2 69
diff --git a/kde-base/kdeadmin/files/digest-kdeadmin-3.2.0_beta2 b/kde-base/kdeadmin/files/digest-kdeadmin-3.2.0_beta2
new file mode 100644
index 000000000000..6b82d9808337
--- /dev/null
+++ b/kde-base/kdeadmin/files/digest-kdeadmin-3.2.0_beta2
@@ -0,0 +1 @@
+MD5 c81b49f264d619fdfc25554bb0a4e305 kdeadmin-3.1.94.tar.bz2 1563352
diff --git a/kde-base/kdeadmin/kdeadmin-3.2.0_beta2.ebuild b/kde-base/kdeadmin/kdeadmin-3.2.0_beta2.ebuild
new file mode 100644
index 000000000000..82fc0c1f1f11
--- /dev/null
+++ b/kde-base/kdeadmin/kdeadmin-3.2.0_beta2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/kdeadmin-3.2.0_beta2.ebuild,v 1.1 2003/12/03 23:14:17 caleb Exp $
+inherit kde-dist
+
+IUSE="pam foreign-sysvinit"
+DESCRIPTION="KDE administration tools (user manager, etc.)"
+KEYWORDS="~x86"
+
+newdepend "pam? ( >=sys-libs/pam-0.72 )
+ foreign-package? ( >=app-arch/rpm-4.0.4-r1 dev-libs/popt )"
+
+use pam && myconf="$myconf --with-pam" || myconf="$myconf --without-pam --with-shadow"
+
+myconf="$myconf --without-rpm"
+DO_NOT_COMPILE="$DO_NOT_COMPILE kpackage"
+
+if [ -z "`use foreign-sysvinit`" ]; then
+ DO_NOT_COMPILE="$DO_NOT_COMPILE ksysv"
+fi
+
+
+# we only want to compile the lilo config module on x86, but there we want to make sure it's
+# always compiled to ensure consistent behaviour of the package across both lilo and grub systems,
+# because configure when left to its own devices will build lilo-config or not basd on whether
+# lilo is present in the path.
+# so, we make configure build it by removing the configure.in.in file that checks for
+# lilo's presense
+src_unpack() {
+
+ kde_src_unpack
+ use x86 && echo > ${S}/lilo-config/configure.in.in
+
+}
+
+# TODO: add nis support