summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
commit89e71ef45253e6d197ba528112eeae6984651626 (patch)
tree043bfec14e51381244a2ec0e91acb3879eae0a5c /kde-base/kalzium
parentInitial import. New dependency for forthcoming Rails 3.1 release. (diff)
downloadhistorical-89e71ef45253e6d197ba528112eeae6984651626.tar.gz
historical-89e71ef45253e6d197ba528112eeae6984651626.tar.bz2
historical-89e71ef45253e6d197ba528112eeae6984651626.zip
[kde-base] KDE SC 4.7.2
Package-Manager: portage-2.2.0_alpha61/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-4.7.2.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index 7a7197de955a..a5235692e712 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.200 2011/09/07 20:13:44 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.201 2011/10/06 18:11:11 alexxy Exp $
+
+*kalzium-4.7.2 (06 Oct 2011)
+
+ 06 Oct 2011; Alexey Shvetsov <alexxy@gentoo.org> +kalzium-4.7.2.ebuild:
+ Version bump KDE SC 4.7.2
*kalzium-4.7.1 (07 Sep 2011)
diff --git a/kde-base/kalzium/kalzium-4.7.2.ebuild b/kde-base/kalzium/kalzium-4.7.2.ebuild
new file mode 100644
index 000000000000..136453746063
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.7.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.7.2.ebuild,v 1.1 2011/10/06 18:11:11 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-base flag-o-matic
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="editor debug +plasma solver"
+
+RDEPEND="
+ $(add_kdebase_dep libkdeedu)
+ editor? ( >=sci-chemistry/openbabel-2.2 )
+"
+DEPEND="${RDEPEND}
+ editor? ( >=dev-cpp/eigen-2.0.3:2 )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ mycmakeargs=(
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)
+ )
+
+ kde4-base_src_configure
+}
+
+src_test(){ :; } #see bug 376911