summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-09-01 16:32:24 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-09-01 16:32:24 +0000
commit0941f8f8b9ab158f571c295f3e1a4db8e2117481 (patch)
tree395111f62c037d6bc60c879297b61c7bbb00ccc4 /kde-base/kalzium
parentstable sparc, bug 282379 (diff)
downloadhistorical-0941f8f8b9ab158f571c295f3e1a4db8e2117481.tar.gz
historical-0941f8f8b9ab158f571c295f3e1a4db8e2117481.tar.bz2
historical-0941f8f8b9ab158f571c295f3e1a4db8e2117481.zip
Version bump KDE 4.3.1
Package-Manager: portage-2.2_rc38/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog8
-rw-r--r--kde-base/kalzium/kalzium-4.3.1.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index f971405b84a4..34db0d4ed429 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.135 2009/08/04 04:28:20 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.136 2009/09/01 14:48:25 tampakrap Exp $
+
+*kalzium-4.3.1 (01 Sep 2009)
+
+ 01 Sep 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kalzium-4.3.1.ebuild:
+ Version bump
04 Aug 2009; Alex Alexander <wired@gentoo.org> ChangeLog:
manifest update (upstream tarball changed)
diff --git a/kde-base/kalzium/kalzium-4.3.1.ebuild b/kde-base/kalzium/kalzium-4.3.1.ebuild
new file mode 100644
index 000000000000..f5f8eb03a9d1
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.3.1.ebuild,v 1.1 2009/09/01 14:48:25 tampakrap Exp $
+
+EAPI="2"
+
+KMNAME="kdeedu"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-meta
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="editor debug +handbook +plasma solver"
+
+COMMON_DEPEND="
+ >=kde-base/libkdeedu-${PV}:${SLOT}[kdeprefix=]
+ editor? ( >=sci-chemistry/openbabel-2.2 )
+"
+DEPEND="${COMMON_DEPEND}
+ editor? ( >=dev-cpp/eigen-2.0.3 )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)"
+
+ kde4-meta_src_configure
+}