summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:47 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:47 +0000
commit86166760b8aa7e1c789581787e2f7bd3d159df87 (patch)
tree3c1095c1c98ae9f6510c9d93134aa0062970a3bd /kde-base/kaddressbook
parentEnabled support for openmpi and mpich2 (see bug #210639). (diff)
downloadhistorical-86166760b8aa7e1c789581787e2f7bd3d159df87.tar.gz
historical-86166760b8aa7e1c789581787e2f7bd3d159df87.tar.bz2
historical-86166760b8aa7e1c789581787e2f7bd3d159df87.zip
Version bump to KDE 3.5.9.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/kaddressbook')
-rw-r--r--kde-base/kaddressbook/ChangeLog8
-rw-r--r--kde-base/kaddressbook/kaddressbook-3.5.9.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/kde-base/kaddressbook/ChangeLog b/kde-base/kaddressbook/ChangeLog
index a7ad404c4561..d23be67d67e6 100644
--- a/kde-base/kaddressbook/ChangeLog
+++ b/kde-base/kaddressbook/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kaddressbook
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/ChangeLog,v 1.86 2008/02/17 03:06:37 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/ChangeLog,v 1.87 2008/02/20 22:33:53 philantrop Exp $
+
+*kaddressbook-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kaddressbook-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
17 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-kaddressbook-3.5.5.ebuild, -kaddressbook-3.5.6.ebuild,
diff --git a/kde-base/kaddressbook/kaddressbook-3.5.9.ebuild b/kde-base/kaddressbook/kaddressbook-3.5.9.ebuild
new file mode 100644
index 000000000000..f24b9bd26b81
--- /dev/null
+++ b/kde-base/kaddressbook/kaddressbook-3.5.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/kaddressbook-3.5.9.ebuild,v 1.1 2008/02/20 22:33:53 philantrop Exp $
+
+KMNAME=kdepim
+EAPI="1"
+inherit kde-meta eutils
+
+DESCRIPTION="The KDE Address Book"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gnokii"
+DEPEND=">=kde-base/libkdepim-${PV}:${SLOT}
+>=kde-base/libkcal-${PV}:${SLOT}
+>=kde-base/certmanager-${PV}:${SLOT}
+>=kde-base/libkdenetwork-${PV}:${SLOT}
+>=kde-base/kontact-${PV}:${SLOT}
+gnokii? ( app-mobilephone/gnokii )"
+
+RDEPEND="${DEPEND}"
+
+KMCOPYLIB="
+ libkdepim libkdepim
+ libkcal libkcal
+ libkleopatra certmanager/lib/
+ libqgpgme libkdenetwork/qgpgme/
+ libkpinterfaces kontact/interfaces/"
+KMEXTRACTONLY="
+ libkdepim/
+ libkdenetwork/
+ libkcal/
+ libemailfunctions/
+ certmanager/
+ kontact/interfaces/
+ akregator
+ kmail/kmailIface.h"
+KMCOMPILEONLY="
+ libkcal/libical/src/libical/
+ libkcal/libical/src/libicalss/
+ akregator/src/librss"
+ # We add them here because they are standard plugins and programs related to kaddressbook but not a dep of any other kdepim program, so they will be lost if noone install them
+KMEXTRA="
+ kabc/
+ kfile-plugins/vcf
+ kontact/plugins/kaddressbook"
+
+src_compile() {
+ myconf="$myconf $(use_with gnokii)"
+ export DO_NOT_COMPILE="libical" && kde-meta_src_compile myconf configure
+ # generate "ical.h"
+ cd "${S}/libkcal/libical/src/libical" && make ical.h
+ # generate "icalss.h"
+ cd "${S}/libkcal/libical/src/libicalss" && make icalss.h
+
+ kde-meta_src_compile "make"
+}