summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
commit171699a002ecd434bf376ad233dbe24d18eb2eb6 (patch)
tree6f899a3828a1e37ab8065f27a01b95c12cdc03e0 /kde-base/dolphin
parentbump to the TeX Live 2011 version (diff)
downloadhistorical-171699a002ecd434bf376ad233dbe24d18eb2eb6.tar.gz
historical-171699a002ecd434bf376ad233dbe24d18eb2eb6.tar.bz2
historical-171699a002ecd434bf376ad233dbe24d18eb2eb6.zip
[kde-base] Version bump KDE SC 4.7.0
Package-Manager: portage-2.2.0_alpha47/cvs/Linux x86_64
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.7.0.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 7370decd894d..2780a63eeef2 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.103 2011/07/09 15:14:29 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.104 2011/07/27 14:04:53 alexxy Exp $
+
+*dolphin-4.7.0 (27 Jul 2011)
+
+ 27 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +dolphin-4.7.0.ebuild:
+ Version bump KDE SC 4.7.0
*dolphin-4.6.5 (09 Jul 2011)
diff --git a/kde-base/dolphin/dolphin-4.7.0.ebuild b/kde-base/dolphin/dolphin-4.7.0.ebuild
new file mode 100644
index 000000000000..1f926c1c4a9c
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.7.0.ebuild,v 1.1 2011/07/27 14:04:53 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-baseapps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( >=dev-libs/shared-desktop-ontologies-0.2 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ $(add_kdebase_dep thumbnailers)
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}