summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-02-19 15:37:14 +0000
committerDan Armak <danarmak@gentoo.org>2005-02-19 15:37:14 +0000
commit15b3dc0c4f2fa1abc939e5b683f874eba992cb1b (patch)
tree49212b9f9719a0ed33a6d021e879cf4c03a0239d /kde-base/dcoppython/dcoppython-3.3.1-r1.ebuild
parentRestored accidentaly removed patchfile, without which the 3.3.1 ebuild didn't... (diff)
downloadhistorical-15b3dc0c4f2fa1abc939e5b683f874eba992cb1b.tar.gz
historical-15b3dc0c4f2fa1abc939e5b683f874eba992cb1b.tar.bz2
historical-15b3dc0c4f2fa1abc939e5b683f874eba992cb1b.zip
dcopperl, dcoppython, qtruby and korundum are being unslotted (moved to SLOT 0) as per bug 80858
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'kde-base/dcoppython/dcoppython-3.3.1-r1.ebuild')
-rw-r--r--kde-base/dcoppython/dcoppython-3.3.1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/kde-base/dcoppython/dcoppython-3.3.1-r1.ebuild b/kde-base/dcoppython/dcoppython-3.3.1-r1.ebuild
new file mode 100644
index 000000000000..dbd080eeca7c
--- /dev/null
+++ b/kde-base/dcoppython/dcoppython-3.3.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dcoppython/dcoppython-3.3.1-r1.ebuild,v 1.1 2005/02/19 15:35:19 danarmak Exp $
+
+KMNAME=kdebindings
+MAXKDEVER=3.3.2
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="KDE: Python bindings for DCOP"
+KEYWORDS="x86"
+IUSE=""
+DEPEND="virtual/python"
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+# Because this installs into /usr/lib/python2.3/..., it doesn't have SLOT=X.Y like the rest of KDE,
+# and it installs into /usr entirely
+SLOT="0"
+src_compile() {
+ kde_src_compile myconf
+ myconf="$myconf --prefix=/usr"
+ kde_src_compile configure make
+}
+