summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-09 15:14:29 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-09 15:14:29 +0000
commit72172e4809ef2a5b1a73e11d73ea8089b70a0c9f (patch)
treeab3bf8b76c601d51fe92eae02f15d2aff11823eb /kde-base/ark
parentBump to an up-to-date version, and add maintainer (diff)
downloadhistorical-72172e4809ef2a5b1a73e11d73ea8089b70a0c9f.tar.gz
historical-72172e4809ef2a5b1a73e11d73ea8089b70a0c9f.tar.bz2
historical-72172e4809ef2a5b1a73e11d73ea8089b70a0c9f.zip
[kde-base] Add KDE SC 4.6.5
Package-Manager: portage-2.2.0_alpha43/cvs/Linux x86_64
Diffstat (limited to 'kde-base/ark')
-rw-r--r--kde-base/ark/ChangeLog7
-rw-r--r--kde-base/ark/ark-4.6.5.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/ark/ChangeLog b/kde-base/ark/ChangeLog
index 07cee946e385..823ba586a6a2 100644
--- a/kde-base/ark/ChangeLog
+++ b/kde-base/ark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ark
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.191 2011/07/06 20:05:41 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.192 2011/07/09 15:14:07 alexxy Exp $
+
+*ark-4.6.5 (09 Jul 2011)
+
+ 09 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +ark-4.6.5.ebuild:
+ Version bump KDE SC 4.6.5
06 Jul 2011; Andreas K. Huettel <dilfridge@gentoo.org> -ark-4.6.2.ebuild,
-ark-4.6.2-r1.ebuild:
diff --git a/kde-base/ark/ark-4.6.5.ebuild b/kde-base/ark/ark-4.6.5.ebuild
new file mode 100644
index 000000000000..8433246d91ed
--- /dev/null
+++ b/kde-base/ark/ark-4.6.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.6.5.ebuild,v 1.1 2011/07/09 15:14:07 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeutils"
+inherit kde4-meta
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+archive +bzip2 debug lzma"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ sys-libs/zlib
+ archive? ( >=app-arch/libarchive-2.6.1[bzip2?,lzma?,zlib] )
+ lzma? ( app-arch/xz-utils )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ )
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ elog "For creating rar archives, install app-arch/rar"
+}