summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-10-13 15:08:44 +0000
committerDan Armak <danarmak@gentoo.org>2005-10-13 15:08:44 +0000
commit22131aa8af7495f4228ba2f7503d22c5d3bb7e66 (patch)
treee9f83e3ff3298524b1f1f56fbd79e608f7848df2 /kde-base/akode
parentMasked pmount (diff)
downloadhistorical-22131aa8af7495f4228ba2f7503d22c5d3bb7e66.tar.gz
historical-22131aa8af7495f4228ba2f7503d22c5d3bb7e66.tar.bz2
historical-22131aa8af7495f4228ba2f7503d22c5d3bb7e66.zip
fix compilation: added missing dep on kdemultimedia-arts and KMCOPYLIB instructions for USE=arts.
Package-Manager: portage-2.0.53_rc5
Diffstat (limited to 'kde-base/akode')
-rw-r--r--kde-base/akode/ChangeLog6
-rw-r--r--kde-base/akode/Manifest4
-rw-r--r--kde-base/akode/akode-3.4.3.ebuild6
3 files changed, 11 insertions, 5 deletions
diff --git a/kde-base/akode/ChangeLog b/kde-base/akode/ChangeLog
index 35b48dba3af7..df0bd24fc5d6 100644
--- a/kde-base/akode/ChangeLog
+++ b/kde-base/akode/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/akode
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/akode/ChangeLog,v 1.21 2005/10/13 00:09:49 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akode/ChangeLog,v 1.22 2005/10/13 15:08:44 danarmak Exp $
+
+ 13 Oct 2005; Dan Armak <danarmak@gentoo.org> akode-3.4.3.ebuild:
+ Added missing dep on kdemultimedia-arts and KMCOPYLIB instructions for
+ USE=arts.
*akode-3.4.3 (13 Oct 2005)
diff --git a/kde-base/akode/Manifest b/kde-base/akode/Manifest
index c23654696012..57428b2986f0 100644
--- a/kde-base/akode/Manifest
+++ b/kde-base/akode/Manifest
@@ -1,8 +1,8 @@
-MD5 bb0f790818142f6756fd972f1d04069f ChangeLog 3108
+MD5 3a5ae36fd7decb50f3740c62fb4a427b ChangeLog 3261
MD5 a443791437dd7163afdf38c26b27cf46 akode-3.4.1-r1.ebuild 1239
MD5 ea2902384b1afd69066f6a3f6d30c5a9 akode-3.4.1.ebuild 1118
MD5 4119db129be52ce806e5f589476ec15c akode-3.4.2.ebuild 1123
-MD5 8e30703485b48b723b21d9f2bb66d68a akode-3.4.3.ebuild 1125
+MD5 a76d20666366c74670dd3f9c6b9a7e4e akode-3.4.3.ebuild 1223
MD5 5503be4dfa64fd0d3bf2165747a97fb0 files/digest-akode-3.4.1 227
MD5 5503be4dfa64fd0d3bf2165747a97fb0 files/digest-akode-3.4.1-r1 227
MD5 453075362e3201c7f44fea430afec5d5 files/digest-akode-3.4.2 308
diff --git a/kde-base/akode/akode-3.4.3.ebuild b/kde-base/akode/akode-3.4.3.ebuild
index 842d2034768e..19b1a0c8b8a2 100644
--- a/kde-base/akode/akode-3.4.3.ebuild
+++ b/kde-base/akode/akode-3.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/akode/akode-3.4.3.ebuild,v 1.1 2005/10/13 00:09:49 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akode/akode-3.4.3.ebuild,v 1.2 2005/10/13 15:08:44 danarmak Exp $
KMNAME=kdemultimedia
MAXKDEVER=$PV
@@ -10,7 +10,7 @@ inherit kde-meta
DESCRIPTION="aRts plugins for various formats"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="alsa arts flac jack mp3 speex vorbis"
-DEPEND="arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
+DEPEND="arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) $(deprange 3.4.1 $MAXKDEVER kde-base/kdemultimedia-arts) )
flac? ( media-libs/flac )
vorbis? ( media-sound/vorbis-tools )
speex? ( media-libs/speex )
@@ -23,6 +23,8 @@ DEPEND="arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
# MISSING: polypaudio - no gentoo ebuild as yet
# TODO: configure needs a pkg-config file for media-sound/jack to detect it
+KMCOPYLIB="libartsbuilder arts/runtime"
+
src_compile() {
use speex && myconf="$myconf --with-extra-includes=/usr/include/speex"
myconf="$myconf $(use_with mp3 libmad) $(use_with flac) $(use_with speex)