summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-03-05 14:50:07 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-03-05 14:50:07 +0000
commit571e812041196f6d1b175a0198c38b1302fac20d (patch)
tree5eebbb2b5488138769206faa05cdbd097648287f /gnustep-libs
parentStable for HPPA (bug #258049). (diff)
downloadhistorical-571e812041196f6d1b175a0198c38b1302fac20d.tar.gz
historical-571e812041196f6d1b175a0198c38b1302fac20d.tar.bz2
historical-571e812041196f6d1b175a0198c38b1302fac20d.zip
Filter out -Werror during build
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'gnustep-libs')
-rw-r--r--gnustep-libs/iconkit/ChangeLog7
-rw-r--r--gnustep-libs/iconkit/iconkit-0.4.0.ebuild11
-rw-r--r--gnustep-libs/popplerkit/ChangeLog8
-rw-r--r--gnustep-libs/popplerkit/popplerkit-0.4.0-r1.ebuild9
4 files changed, 26 insertions, 9 deletions
diff --git a/gnustep-libs/iconkit/ChangeLog b/gnustep-libs/iconkit/ChangeLog
index 108dcfc7cb02..e3a60718e7e9 100644
--- a/gnustep-libs/iconkit/ChangeLog
+++ b/gnustep-libs/iconkit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for gnustep-libs/iconkit
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/iconkit/ChangeLog,v 1.6 2008/11/17 14:00:35 voyageur Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/iconkit/ChangeLog,v 1.7 2009/03/05 14:50:07 voyageur Exp $
+
+ 05 Mar 2009; Bernard Cafarelli <voyageur@gentoo.org> iconkit-0.4.0.ebuild:
+ Filter out -Werror during build
*iconkit-0.4.0 (17 Nov 2008)
diff --git a/gnustep-libs/iconkit/iconkit-0.4.0.ebuild b/gnustep-libs/iconkit/iconkit-0.4.0.ebuild
index e986ac8893f6..cf07d7a1a2d7 100644
--- a/gnustep-libs/iconkit/iconkit-0.4.0.ebuild
+++ b/gnustep-libs/iconkit/iconkit-0.4.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/iconkit/iconkit-0.4.0.ebuild,v 1.1 2008/11/17 14:00:35 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/iconkit/iconkit-0.4.0.ebuild,v 1.2 2009/03/05 14:50:07 voyageur Exp $
inherit gnustep-2
@@ -16,3 +16,10 @@ IUSE=""
DEPEND="media-libs/libpng"
RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${WORKDIR}/Etoile-${PV}"
+ sed -i -e "s/-Werror//" etoile.make || die "sed failed"
+}
diff --git a/gnustep-libs/popplerkit/ChangeLog b/gnustep-libs/popplerkit/ChangeLog
index 7a24a64c7ad1..6132d9422726 100644
--- a/gnustep-libs/popplerkit/ChangeLog
+++ b/gnustep-libs/popplerkit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnustep-libs/popplerkit
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/popplerkit/ChangeLog,v 1.16 2008/12/08 14:31:40 voyageur Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/popplerkit/ChangeLog,v 1.17 2009/03/05 14:48:30 voyageur Exp $
+
+ 05 Mar 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ popplerkit-0.4.0-r1.ebuild:
+ Filter out -Werror during build
*popplerkit-0.4.0-r1 (08 Dec 2008)
diff --git a/gnustep-libs/popplerkit/popplerkit-0.4.0-r1.ebuild b/gnustep-libs/popplerkit/popplerkit-0.4.0-r1.ebuild
index 31ce3cff0c8c..c297a7e5b6a0 100644
--- a/gnustep-libs/popplerkit/popplerkit-0.4.0-r1.ebuild
+++ b/gnustep-libs/popplerkit/popplerkit-0.4.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/popplerkit/popplerkit-0.4.0-r1.ebuild,v 1.1 2008/12/08 14:31:40 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/popplerkit/popplerkit-0.4.0-r1.ebuild,v 1.2 2009/03/05 14:48:30 voyageur Exp $
inherit gnustep-2
@@ -21,8 +21,11 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd "${S}"
+ cd "${WORKDIR}/Etoile-${PV}"
+ sed -i -e "s/-Werror//" etoile.make || die "sed failed"
+
+ cd "${S}"
epatch "${FILESDIR}"/${P}-config-as-needed.patch
}