summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-10 00:02:22 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-10 00:02:22 +0000
commit7db7b5694f92af30f48ce4e42d260b0ba4bb1af0 (patch)
tree1366d0a2b6712f89b967777ff86cc99a922374fa /gnome-extra/libgda
parentadded evidence (diff)
downloadhistorical-7db7b5694f92af30f48ce4e42d260b0ba4bb1af0.tar.gz
historical-7db7b5694f92af30f48ce4e42d260b0ba4bb1af0.tar.bz2
historical-7db7b5694f92af30f48ce4e42d260b0ba4bb1af0.zip
version bump. part of the mergeant package.
Diffstat (limited to 'gnome-extra/libgda')
-rw-r--r--gnome-extra/libgda/ChangeLog7
-rw-r--r--gnome-extra/libgda/files/digest-libgda-0.10.01
-rw-r--r--gnome-extra/libgda/libgda-0.10.0.ebuild96
3 files changed, 103 insertions, 1 deletions
diff --git a/gnome-extra/libgda/ChangeLog b/gnome-extra/libgda/ChangeLog
index 91817fa38c25..6a1a7b64c9c8 100644
--- a/gnome-extra/libgda/ChangeLog
+++ b/gnome-extra/libgda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/libgda
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.14 2003/02/12 06:54:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.15 2003/03/10 00:02:22 liquidx Exp $
+
+*libgda-0.10.0 (09 Mar 2003)
+
+ 09 Mar 2003; Alastair Tse <liquidx@gentoo.org> libgda-0.10.0.ebuild:
+ big version bump. resolves #9683 and #16970.
13 Jan 2003; foser <foser@gentoo.org> libgda-0.2.96-r2.ebuild :
Removed --without-ldap line, it did just the opposite (#12513)
diff --git a/gnome-extra/libgda/files/digest-libgda-0.10.0 b/gnome-extra/libgda/files/digest-libgda-0.10.0
new file mode 100644
index 000000000000..2c787c10c7f4
--- /dev/null
+++ b/gnome-extra/libgda/files/digest-libgda-0.10.0
@@ -0,0 +1 @@
+MD5 7d8ab6091d7a90e4b92fe6d123e6ae88 libgda-0.10.0.tar.bz2 795000
diff --git a/gnome-extra/libgda/libgda-0.10.0.ebuild b/gnome-extra/libgda/libgda-0.10.0.ebuild
new file mode 100644
index 000000000000..dde0b5bbffc8
--- /dev/null
+++ b/gnome-extra/libgda/libgda-0.10.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-0.10.0.ebuild,v 1.1 2003/03/10 00:02:22 liquidx Exp $
+
+IUSE="odbc postgres mysql ldap"
+
+inherit gnome2 gnome.org
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome Database Access Library"
+HOMEPAGE="http://www.gnome-db.org/"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~x86"
+
+RDEPEND=">=gnome-base/ORBit2-2.3.91
+ >=dev-libs/glib-2.0.4
+ >=gnome-base/bonobo-activation-0.7.0
+ >=gnome-base/libbonobo-2.0.0
+ >=dev-libs/libxml2-2.4.23
+ >=gnome-base/gconf-1.2.0
+ >=dev-libs/libxslt-1.0.9
+ >=gnome-base/gnome-vfs-2.0.0
+ dev-libs/popt
+ sys-libs/readline
+ sys-libs/ncurses
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ postgres? ( >=dev-db/postgresql-7.2.1 )
+ odbc? ( >=dev-db/unixODBC-2.0.6 )
+ ldap? ( net-nds/openldap )"
+
+# removing un-ratified use flags
+# sqlite? ( >=dev-db/sqlite-2.4.2 )
+# freetds? ( >=dev-db/freetds-0.53 )
+
+DEPEND=">=dev-util/pkgconfig-0.8
+ >=dev-util/intltool-0.22
+ ${RDEPEND}"
+
+src_compile() {
+
+ local myconf
+
+ if [ -n "`use mysql`" ]; then
+ myconf="--with-mysql=/usr"
+ else
+ myconf="--without-mysql"
+ fi
+
+ if [ -n "`use postgres`" ]; then
+ myconf="${myconf} --with-postgres=/usr"
+ else
+ myconf="${myconf} --without-postgres"
+ fi
+
+ if [ -n "`use odbc`" ]; then
+ myconf="${myconf} --with-odbc=/usr"
+ else
+ myconf="${myconf} --without-odbc"
+ fi
+
+ if [ -n "`use ldap`" ]; then
+ myconf="${myconf} --with-ldap=/usr"
+ else
+ myconf="${myconf} --without-ldap"
+ fi
+
+ # disabling unratified USE flags
+
+ #if [ -n "`use sqlite`" ]; then
+ # myconf="$myconf --with-sqlite=/usr"
+ #else
+ # myconf="$myconf --without-sqlite"
+ #fi
+
+ #if [ -n "`use freetds`" ]; then
+ # myconf="$myconf --with-tds=/usr"
+ #else
+ # myconf="$myconf --without-tds"
+ #fi
+
+ # not setting these, because we should allow
+ # libgda to autodetect the environment if
+ # there are no use flags for these backends.
+
+ #myconf="${myconf} --without-sqlite"
+ #myconf="${myconf} --without-tds"
+ #myconf="${myconf} --without-ibmdb2"
+ #myconf="${myconf} --without-sybase"
+ #myconf="${myconf} --without-oracle"
+ #myconf="${myconf} --without-firebird"
+ #myconf="${myconf} --without-mdb"
+
+ gnome2_src_compile ${myconf}
+
+}