summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-07-29 22:22:37 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-07-29 22:22:37 +0000
commit3d027530610c8df108ac51337ac71e919aeb8e41 (patch)
tree828187ad39be86876e39d45f936a129abebf0c90 /gnome-extra/libgda
parentcleanup (diff)
downloadhistorical-3d027530610c8df108ac51337ac71e919aeb8e41.tar.gz
historical-3d027530610c8df108ac51337ac71e919aeb8e41.tar.bz2
historical-3d027530610c8df108ac51337ac71e919aeb8e41.zip
Fixed bug #4019. (ldap is still broken with this version).
Diffstat (limited to 'gnome-extra/libgda')
-rw-r--r--gnome-extra/libgda/ChangeLog8
-rw-r--r--gnome-extra/libgda/files/digest-libgda-0.2.96-r21
-rw-r--r--gnome-extra/libgda/libgda-0.2.96-r2.ebuild137
3 files changed, 145 insertions, 1 deletions
diff --git a/gnome-extra/libgda/ChangeLog b/gnome-extra/libgda/ChangeLog
index a3a40b830748..b6a0c60fd975 100644
--- a/gnome-extra/libgda/ChangeLog
+++ b/gnome-extra/libgda/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/libgda
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.7 2002/07/27 03:42:30 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.8 2002/07/29 22:22:36 stroke Exp $
+
+*libgda-0.2.96-r2 (30 Jul 2002)
+
+ 30 Jul 2002; Gabriele Giorgetti <stroke@gentoo.org> libgda-0.2.96-r2.ebuild:
+
+ Fixed bug #4019. (openldap support is still broken with this version).
*libgda-0.8.192 (26 Jul 2002)
diff --git a/gnome-extra/libgda/files/digest-libgda-0.2.96-r2 b/gnome-extra/libgda/files/digest-libgda-0.2.96-r2
new file mode 100644
index 000000000000..a359b7677236
--- /dev/null
+++ b/gnome-extra/libgda/files/digest-libgda-0.2.96-r2
@@ -0,0 +1 @@
+MD5 7c52b9a76b8b7669b795393de1ddc322 libgda-0.2.96.tar.gz 1327366
diff --git a/gnome-extra/libgda/libgda-0.2.96-r2.ebuild b/gnome-extra/libgda/libgda-0.2.96-r2.ebuild
new file mode 100644
index 000000000000..aaad0578baa8
--- /dev/null
+++ b/gnome-extra/libgda/libgda-0.2.96-r2.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-0.2.96-r2.ebuild,v 1.1 2002/07/29 22:22:37 stroke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="gda lib"
+SRC_URI="ftp://ftp.gnome-db.org/pub/gnome-db/sources/latest/${P}.tar.gz
+ ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/gnome-db"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86"
+
+
+RDEPEND="virtual/glibc
+ >=gnome-base/gconf-1.0.4-r2
+ <gnome-base/gconf-1.1
+ >=gnome-base/oaf-0.6.6-r1
+ >=gnome-base/bonobo-1.0.9-r1
+ >=dev-libs/libxslt-1.0.1
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=dev-perl/CORBA-ORBit-0.4.3
+ >=dev-db/sqlite-2.0.8
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )"
+
+# ldap support is currently broken (this fixes bug #4019)
+# ldap? ( >=net-nds/openldap-1.2.11 )"
+# stroke@gentoo.org
+
+DEPEND="${RDEPEND}
+ >=app-text/scrollkeeper-0.2-r3
+ sys-apps/which"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}-gentoo.patch || die "Patch for gcc-3.1 failed"
+
+}
+
+src_compile() {
+
+ local myconf
+
+ if [ "`use mysql`" ]
+ then
+ myconf="--with-mysql=/usr"
+ fi
+
+# if [ "`use ldap`" ]
+# then
+# myconf="$myconf --with-ldap=/usr"
+# fi
+#
+# LDAP support is currently broken
+ myconf="$myconf --without-ldap"
+
+ if [ "`use odbc`" ]
+ then
+ myconf="$myconf --with-odbc"
+ fi
+
+ if [ "`use postgres`" ]
+ then
+ myconf="$myconf --with-postgres=/usr"
+ fi
+
+ # Wierd one, it dont detect bonobo. If someone could have a look
+ # and fix if i havent gotten to it yet.
+# myconf="$myconf --disable-bonobotest"
+
+ # Do not compile buildin sqlite
+ cp configure configure.orig
+ grep -v sqlite configure.orig >configure
+ chmod +x configure
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ $myconf || die
+
+ # Build and use an external version of sqlite since some versions
+ # of libgda have a bug where the buildin do not compile.
+ # Also cant hurt to use the latest version of sqlite :)
+ mv ${S}/providers/gda-default-server/gda-default.h \
+ ${S}/gda-default.h.orig
+ sed -e 's/\"build_sqlite\/sqlite\.h\"/<sqlite.h>/' \
+ ${S}/gda-default.h.orig > \
+ ${S}/providers/gda-default-server/gda-default.h || die
+ ln -s /usr/lib/libsqlite.a \
+ ${S}/providers/gda-default-server/sqlite/libsqlite.a
+ mv providers/gda-default-server/Makefile \
+ providers/gda-default-server/Makefile.orig
+ grep -v '= sqlite' providers/gda-default-server/Makefile.orig > \
+ providers/gda-default-server/Makefile
+
+ # Doesn't work with -j 4 (hallski)
+ make LDFLAGS="-lncurses" LIBREADLINE="-lreadline -lncurses" || die
+}
+
+src_install() {
+
+ cd ${S}/doc
+ cp Makefile Makefile.old
+ sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
+ rm Makefile.old
+ cd ${S}
+
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ GDA_oafinfodir=${D}/usr/share/oaf \
+ install || die
+
+ # Not needed as we build sqlite seperately
+# dobin providers/gda-default-server/build_sqlite/{lemon,sqlite}
+
+ dodoc AUTHORS COPYING.* ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+
+pkg_postrm() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+