summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-05 19:59:10 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-05 19:59:10 +0000
commit03b91c44fa0267df11ec2926426afd9b94c480bd (patch)
treec77a941a65e7e76b26a6ec0693a4778819f60484 /gnome-extra/gtkhtml
parent~x86 -> x86 and added ~ppc (diff)
downloadhistorical-03b91c44fa0267df11ec2926426afd9b94c480bd.tar.gz
historical-03b91c44fa0267df11ec2926426afd9b94c480bd.tar.bz2
historical-03b91c44fa0267df11ec2926426afd9b94c480bd.zip
version bump
Diffstat (limited to 'gnome-extra/gtkhtml')
-rw-r--r--gnome-extra/gtkhtml/ChangeLog7
-rw-r--r--gnome-extra/gtkhtml/files/digest-gtkhtml-1.1.102
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-1.1.10.ebuild141
3 files changed, 149 insertions, 1 deletions
diff --git a/gnome-extra/gtkhtml/ChangeLog b/gnome-extra/gtkhtml/ChangeLog
index bea12c3af896..845779dcff72 100644
--- a/gnome-extra/gtkhtml/ChangeLog
+++ b/gnome-extra/gtkhtml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/gtkhtml
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/ChangeLog,v 1.29 2003/03/29 03:01:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/ChangeLog,v 1.30 2003/04/05 19:59:10 liquidx Exp $
+
+*gtkhtml-1.1.10 (05 Apr 2003)
+
+ 05 Apr 2003; Alastair Tse <liquidx@gentoo.org> gtkhtml-1.1.10.ebuild:
+ version bump
*gtkhtml-3.0.1 (13 Mar 2003)
diff --git a/gnome-extra/gtkhtml/files/digest-gtkhtml-1.1.10 b/gnome-extra/gtkhtml/files/digest-gtkhtml-1.1.10
new file mode 100644
index 000000000000..90112df02db3
--- /dev/null
+++ b/gnome-extra/gtkhtml/files/digest-gtkhtml-1.1.10
@@ -0,0 +1,2 @@
+MD5 e8db3818790703cb358d0e3102ed6d77 /gtkhtml-1.1.10.ebuild 4066
+MD5 8647407560e4b61ba4a12653b9cc8869 gtkhtml-1.1.10.tar.bz2 1029542
diff --git a/gnome-extra/gtkhtml/gtkhtml-1.1.10.ebuild b/gnome-extra/gtkhtml/gtkhtml-1.1.10.ebuild
new file mode 100644
index 000000000000..1c6e72fe9d53
--- /dev/null
+++ b/gnome-extra/gtkhtml/gtkhtml-1.1.10.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/gtkhtml-1.1.10.ebuild,v 1.1 2003/04/05 19:59:10 liquidx Exp $
+
+IUSE="nls gnome"
+
+inherit gnome.org libtool
+
+MY_PV="`echo ${PV} | cut -d. -f1,2`"
+S="${WORKDIR}/${P}"
+DESCRIPTION="Lightweight HTML rendering/printing/editing engine."
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2.1"
+# This one lets gtkhtml-1.0 compiled stuff work, but some stuff do
+# not compile, so not sure as to what to set SLOT to .. it could be
+# that new versions will support 1.[12] of gtkhtml ...
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+# peg gtkhtml at gal-0.23 because it might get confused with gal-1.99
+RDEPEND="=gnome-extra/gal-0.24*
+ <gnome-base/control-center-1.99.0
+ >=gnome-base/libghttp-1.0.9-r1
+ >=dev-libs/libunicode-0.4-r1
+ >=gnome-base/gnome-print-0.34
+ >=gnome-base/bonobo-1.0.20
+ nls? ( sys-devel/gettext
+ >=dev-util/intltool-0.11 )
+ <gnome-base/libglade-0.99.0
+ <gnome-base/gconf-1.1.0"
+# gnome? ( <gnome-base/gconf-1.1.0 )
+# Borks without gconf in most cases
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ use nls || myconf="${myconf} --disable-nls"
+
+ # Evo users need to have bonobo support
+ #use bonobo \
+ # && myconf="${myconf} --with-bonobo" \
+ # || myconf="${myconf} --without-bonobo"
+
+ # Otherwise it will use the wrong include dir
+ #use gnome \
+ # && myconf="${myconf} --with-gconf" \
+ # || myconf="${myconf} --without-gconf"
+ myconf="${myconf} --with-gconf"
+# Borks without gconf in most cases
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ emake || die "Package building failed."
+}
+
+# This function converts a pkgconfig config type file to
+# a Conf.sh type file used by gnome-config.
+#
+# Usage: conv_pkgconfig_confsh foo.pc
+#
+# <azarah@gentoo.org> (9 Nov 2002)
+conv_pkgconfig_confsh() {
+
+ local pkgconfig_file="$1"
+ local confsh_file="${pkgconfig_file%%-*}Conf.sh"
+ local package_name="`echo ${pkgconfig_file%%-*} | awk '{print toupper($0)}'`"
+ local tmpfile="${T}/$$.env"
+
+ [ "$#" -ne 1 ] && return 1
+ [ ! -f ${D}/usr/lib/pkgconfig/${pkgconfig_file} ] && return 1
+
+ # Remove bogus info and convert to bash type file we can
+ # source ...
+ sed -e 's|: *|=|g' \
+ -e '/^$/ d' \
+ -e 's|$|"|g' \
+ -e 's|=|="|g' \
+ -e 's|Libs=|libs=|' \
+ -e 's|Cflags=|cflags=|' \
+ -e '/^Name.*/ d' \
+ -e '/^Description.*/ d' \
+ -e '/^Version.*/ d' \
+ ${D}/usr/lib/pkgconfig/${pkgconfig_file} > ${tmpfile}
+
+ source ${tmpfile}
+
+ # Ok, generate our Conf.sh file
+ cat > ${D}/usr/lib/${confsh_file} <<CONFSHEND
+#
+# Configuration file for using the ${package_name} library in GNOME applications
+#
+${package_name}_LIBDIR="-L${libdir}"
+${package_name}_LIBS="${libs}"
+${package_name}_INCLUDEDIR="${cflags}"
+${package_name}_DATADIR="${gtkhtml_datadir}"
+MODULE_VERSION="${module_version}"
+
+CONFSHEND
+
+ # Fix permissions
+ fperms 0755 /usr/lib/${confsh_file}
+}
+
+src_install() {
+ local fullname=""
+
+ einstall || die
+
+ # Fix the double entry in Control Center
+ rm -f ${D}/usr/share/control-center/capplets/gtkhtml-properties.desktop
+
+ # This next big gets gtkhtml-1.1 to be compadible with gtkhtml-1.0.
+ # We basically generate a /usr/lib/gtkhtmlConf.sh so that gnome-config
+ # will see gtkhtml-1.1 and other older gnome apps should then be able
+ # to use it. We also create libgtkhtml.so and libgtkhtml.so.20 symlinks,
+ # and /usr/share/gtkhtml-1.1/gtkhtml symlinks for apps compiled against
+ # older gtkhtml to find their libs, and data .idl files.
+ #
+ # <azarah@gentoo.org> (9 Nov 2002)
+ conv_pkgconfig_confsh ${PN}-${MY_PV}.pc
+
+ # Add some type of backward compat for libs...
+ fullname="`eval basename \`readlink ${D}/usr/lib/lib${PN}-${MY_PV}.so\``"
+ dosym ${fullname##*/} /usr/lib/lib${PN}.so
+ dosym ${fullname##*/} /usr/lib/lib${PN}.so.20
+
+ # For older apps to be able to find the data...
+ dosym '.' /usr/share/${PN}-${MY_PV}/${PN}
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+}
+