summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2006-09-07 04:16:14 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2006-09-07 04:16:14 +0000
commitef23a976225bb6793cbfab56f6ccddb40c6715ce (patch)
tree8316e1dec90d718b31daa5d1eb8bc264cfad87a1 /gnome-extra/deskbar-applet
parentgnome 2.16 (diff)
downloadhistorical-ef23a976225bb6793cbfab56f6ccddb40c6715ce.tar.gz
historical-ef23a976225bb6793cbfab56f6ccddb40c6715ce.tar.bz2
historical-ef23a976225bb6793cbfab56f6ccddb40c6715ce.zip
gnome 2.16
Package-Manager: portage-2.1.1_rc1-r2
Diffstat (limited to 'gnome-extra/deskbar-applet')
-rw-r--r--gnome-extra/deskbar-applet/ChangeLog9
-rw-r--r--gnome-extra/deskbar-applet/deskbar-applet-2.16.0.ebuild44
-rw-r--r--gnome-extra/deskbar-applet/files/deskbar-applet-2.15.3-multilib.patch66
-rw-r--r--gnome-extra/deskbar-applet/files/digest-deskbar-applet-2.16.03
4 files changed, 121 insertions, 1 deletions
diff --git a/gnome-extra/deskbar-applet/ChangeLog b/gnome-extra/deskbar-applet/ChangeLog
index e7007ab0fdf2..f6f92f71e73b 100644
--- a/gnome-extra/deskbar-applet/ChangeLog
+++ b/gnome-extra/deskbar-applet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/deskbar-applet
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/deskbar-applet/ChangeLog,v 1.20 2006/08/19 00:57:36 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/deskbar-applet/ChangeLog,v 1.21 2006/09/07 03:46:55 dang Exp $
+
+*deskbar-applet-2.16.0 (07 Sep 2006)
+
+ 07 Sep 2006; Daniel Gryniewicz <dang@gentoo.org>
+ +files/deskbar-applet-2.15.3-multilib.patch,
+ +deskbar-applet-2.16.0.ebuild:
+ New version for gnome 2.16
19 Aug 2006; Bryan Østergaard <kloeri@gentoo.org>
deskbar-applet-2.14.2.ebuild:
diff --git a/gnome-extra/deskbar-applet/deskbar-applet-2.16.0.ebuild b/gnome-extra/deskbar-applet/deskbar-applet-2.16.0.ebuild
new file mode 100644
index 000000000000..fce242b680a4
--- /dev/null
+++ b/gnome-extra/deskbar-applet/deskbar-applet-2.16.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/deskbar-applet/deskbar-applet-2.16.0.ebuild,v 1.1 2006/09/07 03:46:55 dang Exp $
+
+inherit gnome2 eutils autotools python
+
+DESCRIPTION="An Omnipresent Versatile Search Interface"
+HOMEPAGE="http://raphael.slinckx.net/deskbar/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="eds"
+
+RDEPEND=">=dev-lang/python-2.4
+ >=x11-libs/gtk+-2.6
+ >=dev-python/pygtk-2.6
+ >=dev-python/gnome-python-2.10
+ >=gnome-base/gnome-desktop-2.10
+ >=sys-apps/dbus-0.60
+ >=dev-python/gnome-python-desktop-2.14.0
+ >=dev-python/gnome-python-extras-2.12
+ >=gnome-base/gconf-2
+ dev-python/elementtree
+ eds? ( >=gnome-extra/evolution-data-server-1.7.92 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable eds evolution) --exec-prefix=/usr"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix installing libs into pythondir
+ epatch ${FILESDIR}/${PN}-2.15.3-multilib.patch
+
+ AT_M4DIR="m4" eautoreconf
+}
diff --git a/gnome-extra/deskbar-applet/files/deskbar-applet-2.15.3-multilib.patch b/gnome-extra/deskbar-applet/files/deskbar-applet-2.15.3-multilib.patch
new file mode 100644
index 000000000000..97a308cf42fa
--- /dev/null
+++ b/gnome-extra/deskbar-applet/files/deskbar-applet-2.15.3-multilib.patch
@@ -0,0 +1,66 @@
+diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.15.3.orig/deskbar/evolution/Makefile.am deskbar-applet-2.15.3/deskbar/evolution/Makefile.am
+--- deskbar-applet-2.15.3.orig/deskbar/evolution/Makefile.am 2006-05-22 17:30:21.000000000 -0400
++++ deskbar-applet-2.15.3/deskbar/evolution/Makefile.am 2006-06-14 13:45:10.000000000 -0400
+@@ -1,6 +1,6 @@
+ INCLUDES = $(PYTHON_INCLUDES) $(EVOLUTION_CFLAGS)
+
+-_evolutiondir = $(pythondir)/deskbar/evolution
++_evolutiondir = $(pyexecdir)/deskbar/evolution
+ _evolution_LTLIBRARIES = _evolution.la
+ _evolution_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_evolution
+ _evolution_la_LIBADD = $(EVOLUTION_LIBS)
+diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.15.3.orig/deskbar/gdmclient/Makefile.am deskbar-applet-2.15.3/deskbar/gdmclient/Makefile.am
+--- deskbar-applet-2.15.3.orig/deskbar/gdmclient/Makefile.am 2006-05-31 07:36:27.000000000 -0400
++++ deskbar-applet-2.15.3/deskbar/gdmclient/Makefile.am 2006-06-14 13:46:02.000000000 -0400
+@@ -1,6 +1,6 @@
+ INCLUDES = $(PYTHON_INCLUDES) $(DESKBAR_CFLAGS)
+
+-_gdmclientdir = $(pythondir)/deskbar/gdmclient
++_gdmclientdir = $(pyexecdir)/deskbar/gdmclient
+ _gdmclient_LTLIBRARIES = _gdmclient.la
+ _gdmclient_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_gdmclient
+ _gdmclient_la_LIBADD = $(DESKBAR_LIBS)
+diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.15.3.orig/deskbar/gnomedesktop/Makefile.am deskbar-applet-2.15.3/deskbar/gnomedesktop/Makefile.am
+--- deskbar-applet-2.15.3.orig/deskbar/gnomedesktop/Makefile.am 2006-05-22 17:30:21.000000000 -0400
++++ deskbar-applet-2.15.3/deskbar/gnomedesktop/Makefile.am 2006-06-14 13:45:10.000000000 -0400
+@@ -1,6 +1,6 @@
+ INCLUDES = $(PYTHON_INCLUDES) $(DESKBAR_CFLAGS)
+
+-_gnomedesktopdir = $(pythondir)/deskbar/gnomedesktop
++_gnomedesktopdir = $(pyexecdir)/deskbar/gnomedesktop
+ _gnomedesktop_LTLIBRARIES = _gnomedesktop.la
+ _gnomedesktop_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_gnomedesktop
+ _gnomedesktop_la_LIBADD = $(DESKBAR_LIBS)
+diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.15.3.orig/deskbar/iconentry/Makefile.am deskbar-applet-2.15.3/deskbar/iconentry/Makefile.am
+--- deskbar-applet-2.15.3.orig/deskbar/iconentry/Makefile.am 2006-05-22 17:30:22.000000000 -0400
++++ deskbar-applet-2.15.3/deskbar/iconentry/Makefile.am 2006-06-14 13:45:10.000000000 -0400
+@@ -1,6 +1,6 @@
+ INCLUDES = $(PYTHON_INCLUDES) $(DESKBAR_CFLAGS)
+
+-_iconentrydir = $(pythondir)/deskbar/iconentry
++_iconentrydir = $(pyexecdir)/deskbar/iconentry
+ _iconentry_LTLIBRARIES = _iconentry.la
+ _iconentry_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_iconentry
+ _iconentry_la_LIBADD = $(DESKBAR_LIBS)
+diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.15.3.orig/deskbar/keybinder/Makefile.am deskbar-applet-2.15.3/deskbar/keybinder/Makefile.am
+--- deskbar-applet-2.15.3.orig/deskbar/keybinder/Makefile.am 2006-05-22 17:30:22.000000000 -0400
++++ deskbar-applet-2.15.3/deskbar/keybinder/Makefile.am 2006-06-14 13:45:10.000000000 -0400
+@@ -1,6 +1,6 @@
+ INCLUDES = $(PYTHON_INCLUDES) $(DESKBAR_CFLAGS)
+
+-_keybinderdir = $(pythondir)/deskbar/keybinder
++_keybinderdir = $(pyexecdir)/deskbar/keybinder
+ _keybinder_LTLIBRARIES = _keybinder.la
+ _keybinder_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_keybinder
+ _keybinder_la_LIBADD = $(DESKBAR_LIBS)
+diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.15.3.orig/deskbar/osutils/Makefile.am deskbar-applet-2.15.3/deskbar/osutils/Makefile.am
+--- deskbar-applet-2.15.3.orig/deskbar/osutils/Makefile.am 2006-05-22 17:30:22.000000000 -0400
++++ deskbar-applet-2.15.3/deskbar/osutils/Makefile.am 2006-06-14 13:45:10.000000000 -0400
+@@ -1,6 +1,6 @@
+ INCLUDES = $(PYTHON_INCLUDES) $(DESKBAR_CFLAGS)
+
+-_osutilsdir = $(pythondir)/deskbar/osutils
++_osutilsdir = $(pyexecdir)/deskbar/osutils
+ _osutils_LTLIBRARIES = _osutils.la
+ _osutils_la_LDFLAGS = -module -avoid-version init_osutils
+ _osutils_la_LIBADD = $(DESKBAR_LIBS)
diff --git a/gnome-extra/deskbar-applet/files/digest-deskbar-applet-2.16.0 b/gnome-extra/deskbar-applet/files/digest-deskbar-applet-2.16.0
new file mode 100644
index 000000000000..d6e803bfc518
--- /dev/null
+++ b/gnome-extra/deskbar-applet/files/digest-deskbar-applet-2.16.0
@@ -0,0 +1,3 @@
+MD5 9f14a65f75142cd5b233bf9376a1f946 deskbar-applet-2.16.0.tar.bz2 613562
+RMD160 f90a860d68af203f222f59f7b8aceba76b14810d deskbar-applet-2.16.0.tar.bz2 613562
+SHA256 835fcc0260f16bb462e476f277b46df0d5f77fd7afc8f9aab1159daaee685582 deskbar-applet-2.16.0.tar.bz2 613562