summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2009-03-17 15:17:37 +0000
committerMart Raudsepp <leio@gentoo.org>2009-03-17 15:17:37 +0000
commite3e226e6f63522a67cafa461bac4cc2e242e1868 (patch)
treecdb5d8b7d35204db31a894c30b203465eb98e891 /gnome-base/orbit/orbit-2.14.17.ebuild
parentFix for manifest failure. Bug 262801. (diff)
downloadhistorical-e3e226e6f63522a67cafa461bac4cc2e242e1868.tar.gz
historical-e3e226e6f63522a67cafa461bac4cc2e242e1868.tar.bz2
historical-e3e226e6f63522a67cafa461bac4cc2e242e1868.zip
Fix cross-compilation, bug 262741. Thanks to Maksim Melnikau.
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'gnome-base/orbit/orbit-2.14.17.ebuild')
-rw-r--r--gnome-base/orbit/orbit-2.14.17.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnome-base/orbit/orbit-2.14.17.ebuild b/gnome-base/orbit/orbit-2.14.17.ebuild
index c6a32325d7b4..676d5f91d5c6 100644
--- a/gnome-base/orbit/orbit-2.14.17.ebuild
+++ b/gnome-base/orbit/orbit-2.14.17.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.17.ebuild,v 1.1 2009/03/08 00:59:36 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.17.ebuild,v 1.2 2009/03/17 15:17:37 leio Exp $
GCONF_DEBUG="no"
-inherit gnome2
+inherit gnome2 toolchain-funcs
MY_P="ORBit2-${PV}"
PVP=(${PV//[-\._]/ })
@@ -34,6 +34,13 @@ src_compile() {
# for more information. Please don't remove -- 8/18/06
unset IDL_DIR
+ # We need to use the hosts IDL compiler if cross-compiling, bug #262741
+ if tc-is-cross-compiler; then
+ # check that host version is present and executable
+ [ -x /usr/bin/orbit-idl-2 ] || die "Please emerge =gnome-base/orbit-${P} on the host system first"
+ G2CONF="${G2CONF} --with-idl-compiler=/usr/bin/orbit-idl-2"
+ fi
+
gnome2_src_compile
}