summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2005-12-01 19:42:29 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2005-12-01 19:42:29 +0000
commit7e2762f995a1cc1dc607932c0bc1a58d74daf5ab (patch)
treea228753e10c7cf25fd52b635ce02b6e289bc9e5f /gnome-base/nautilus/nautilus-2.12.2.ebuild
parentNew upstream release (diff)
downloadhistorical-7e2762f995a1cc1dc607932c0bc1a58d74daf5ab.tar.gz
historical-7e2762f995a1cc1dc607932c0bc1a58d74daf5ab.tar.bz2
historical-7e2762f995a1cc1dc607932c0bc1a58d74daf5ab.zip
New upstream version
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'gnome-base/nautilus/nautilus-2.12.2.ebuild')
-rw-r--r--gnome-base/nautilus/nautilus-2.12.2.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/gnome-base/nautilus/nautilus-2.12.2.ebuild b/gnome-base/nautilus/nautilus-2.12.2.ebuild
new file mode 100644
index 000000000000..c4785208d4f2
--- /dev/null
+++ b/gnome-base/nautilus/nautilus-2.12.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-2.12.2.ebuild,v 1.1 2005/12/01 19:42:29 dang Exp $
+
+inherit virtualx gnome2 eutils
+
+DESCRIPTION="A file manager for the GNOME desktop"
+HOMEPAGE="http://www.gnome.org/projects/nautilus/"
+
+LICENSE="GPL-2 LGPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+# cups flac gstreamer mad ogg vorbis
+
+RDEPEND=">=media-libs/libart_lgpl-2.3.10
+ >=gnome-base/libbonobo-2.1
+ >=gnome-base/eel-2.12
+ >=media-sound/esound-0.2.27
+ >=dev-libs/glib-2.6
+ >=gnome-base/gnome-desktop-2.9.91
+ >=gnome-base/libgnome-2.1.1
+ >=gnome-base/libgnomeui-2.6
+ >=gnome-base/gnome-vfs-2.11.1
+ >=gnome-base/orbit-2.4
+ >=x11-libs/pango-1.1.2
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/librsvg-2.0.1
+ >=dev-libs/libxml2-2.4.7
+ >=x11-libs/startup-notification-0.8
+ >=media-libs/libexif-0.5.12
+ >=gnome-base/gconf-2
+ dev-libs/popt
+ || ( (
+ x11-libs/libICE
+ x11-libs/libSM )
+ virtual/x11 )
+ virtual/eject"
+# !gstreamer? ( vorbis? ( media-sound/vorbis-tools ) )
+# gstreamer? (
+# >=media-libs/gstreamer-0.8
+# >=media-libs/gst-plugins-0.8
+# >=media-plugins/gst-plugins-gnomevfs-0.8
+# mad? ( >=media-plugins/gst-plugins-mad-0.8 )
+# ogg? ( >=media-plugins/gst-plugins-ogg-0.8 )
+# vorbis? ( >=media-plugins/gst-plugins-vorbis-0.8 )
+# flac? ( >=media-plugins/gst-plugins-flac-0.8 ) )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.28
+ >=dev-util/pkgconfig-0.9"
+
+PDEPEND=">=x11-themes/gnome-icon-theme-1.1.91
+ x11-themes/gnome-themes"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README THANKS TODO"
+USE_DESTDIR="1"
+
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ epatch ${FILESDIR}/${PN}-2.12.1-symlink-del.patch
+}
+
+src_test() {
+ if hasq userpriv $FEATURES ;
+ then
+ Xmake check || die "Test phase failed"
+ fi
+}