summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-29 08:31:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-29 08:31:07 +0000
commit60543421791f472e051c0ebaf8a968c3dd300294 (patch)
tree4c9acef240bd05a69ba613d855034064d46e997d /games-util/fteqcc/fteqcc-2501.ebuild
parentEAPI=2; respect CC (diff)
downloadhistorical-60543421791f472e051c0ebaf8a968c3dd300294.tar.gz
historical-60543421791f472e051c0ebaf8a968c3dd300294.tar.bz2
historical-60543421791f472e051c0ebaf8a968c3dd300294.zip
EAPI=2; more toolchain respect
Package-Manager: portage-2.1.6.4/cvs/Linux 2.6.28.1 i686
Diffstat (limited to 'games-util/fteqcc/fteqcc-2501.ebuild')
-rw-r--r--games-util/fteqcc/fteqcc-2501.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/games-util/fteqcc/fteqcc-2501.ebuild b/games-util/fteqcc/fteqcc-2501.ebuild
index 298beb7b1efb..317debeb2a8d 100644
--- a/games-util/fteqcc/fteqcc-2501.ebuild
+++ b/games-util/fteqcc/fteqcc-2501.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/fteqcc/fteqcc-2501.ebuild,v 1.3 2007/07/02 00:08:48 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/fteqcc/fteqcc-2501.ebuild,v 1.4 2009/01/29 08:31:07 mr_bones_ Exp $
-inherit eutils
+EAPI=2
+inherit eutils flag-o-matic
DESCRIPTION="QC compiler"
HOMEPAGE="http://fteqw.sourceforge.net/"
@@ -19,15 +20,16 @@ RDEPEND=""
S=${WORKDIR}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-cleanup-source.patch
sed -i \
+ -e '/^CC/d' \
-e "s: -O3 : :g" \
-e "s: -s : :g" \
+ -e 's/-o fteqcc.bin/$(LDFLAGS) -o fteqcc.bin/' \
Makefile || die "sed failed"
edos2unix readme.txt
+ append-flags -DQCCONLY
}
src_compile() {