summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-07-01 06:46:24 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-07-01 06:46:24 +0000
commitd3a5dc4f64127c10521f59ee47a602765cc67f76 (patch)
tree7011114243b57a6aca50416edd843e0f0c76b948 /games-strategy
parentMarked stable on mips. (diff)
downloadhistorical-d3a5dc4f64127c10521f59ee47a602765cc67f76.tar.gz
historical-d3a5dc4f64127c10521f59ee47a602765cc67f76.tar.bz2
historical-d3a5dc4f64127c10521f59ee47a602765cc67f76.zip
version bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog8
-rw-r--r--games-strategy/wesnoth/Manifest4
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.9.31
-rw-r--r--games-strategy/wesnoth/wesnoth-0.9.3.ebuild45
4 files changed, 56 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index b3dbff4ec2d3..60d066605838 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.51 2005/06/08 16:51:59 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.52 2005/07/01 06:46:24 mr_bones_ Exp $
+
+*wesnoth-0.9.3 (30 Jun 2005)
+
+ 30 Jun 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +wesnoth-0.9.3.ebuild:
+ version bump
08 Jun 2005; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-0.9.2.ebuild:
Fix error in packaging (bug #95466)
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 0c79745c1c8f..471e4c757647 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,6 +1,8 @@
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 7c47e4ea083a70208dbd3af0fd5762ea wesnoth-0.9.1.ebuild 1526
MD5 8fb0482ca0c49d7e4ba90649ae6ba1a1 wesnoth-0.9.2.ebuild 1620
-MD5 8f84ea69f2bad97aa47496e3881d35fd ChangeLog 7094
+MD5 94b40ec66657618711d7685f9fa9d053 ChangeLog 7220
+MD5 d9b716f96dd6348b907dfb2319ae80a4 wesnoth-0.9.3.ebuild 1207
+MD5 5dc47eb07568e52d6a8cfadc4f278924 files/digest-wesnoth-0.9.3 67
MD5 d311e24bad645f1e02171305e415574c files/digest-wesnoth-0.9.1 139
MD5 c2e828026f26a0373ee5546086427c60 files/digest-wesnoth-0.9.2 139
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.9.3 b/games-strategy/wesnoth/files/digest-wesnoth-0.9.3
new file mode 100644
index 000000000000..04b4365e2b47
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.9.3
@@ -0,0 +1 @@
+MD5 833bd6995a26c873485750875607f127 wesnoth-0.9.3.tar.gz 38203711
diff --git a/games-strategy/wesnoth/wesnoth-0.9.3.ebuild b/games-strategy/wesnoth/wesnoth-0.9.3.ebuild
new file mode 100644
index 000000000000..e98d09a2b86a
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.9.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.9.3.ebuild,v 1.1 2005/07/01 06:46:24 mr_bones_ Exp $
+
+inherit eutils flag-o-matic games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="editor gnome kde lite nls server tools"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/freetype-2
+ media-libs/sdl-net
+ sys-libs/zlib
+ virtual/x11"
+
+src_compile() {
+ filter-flags -ftracer -fomit-frame-pointer
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable lite) \
+ $(use_enable server) \
+ $(use_enable server campaign-server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable nls) \
+ $(use_with gnome) \
+ $(use_with kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/"{icons,applnk,applications} "${D}/usr/share/"
+ dodoc MANUAL changelog
+ prepgamesdirs
+}