summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-04-26 03:59:02 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-04-26 03:59:02 +0000
commit68c0efd7e08e000e9da796448371ddb44a64e706 (patch)
treefc486a563caa3ca5bdb8bf923125b4b3c79bb599 /games-strategy
parentremove ed and bc (diff)
downloadhistorical-68c0efd7e08e000e9da796448371ddb44a64e706.tar.gz
historical-68c0efd7e08e000e9da796448371ddb44a64e706.tar.bz2
historical-68c0efd7e08e000e9da796448371ddb44a64e706.zip
version bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog8
-rw-r--r--games-strategy/wesnoth/Manifest4
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.9.12
-rw-r--r--games-strategy/wesnoth/wesnoth-0.9.1.ebuild62
4 files changed, 74 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 124fb26fdee9..109e08eebef1 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.47 2005/04/11 23:47:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.48 2005/04/26 03:59:02 mr_bones_ Exp $
+
+*wesnoth-0.9.1 (26 Apr 2005)
+
+ 26 Apr 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +wesnoth-0.9.1.ebuild:
+ version bump
*wesnoth-0.9.0 (11 Apr 2005)
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index b859010a1e62..0c166652ad2f 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,8 +1,10 @@
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 d5bb29547496f56562edfe9cb5fb44b3 wesnoth-0.9.0.ebuild 1549
MD5 93581e11441f3cd875599dfbea67f87a wesnoth-0.8.10.ebuild 1766
+MD5 3d42fe991cec478a2bc67e201313986b wesnoth-0.9.1.ebuild 1531
MD5 c3b7385d21ce32866abc499da8dc32b1 wesnoth-0.8.11.ebuild 1611
-MD5 d208f328dbecbd13097b5450a746a7e1 ChangeLog 6553
+MD5 26fcdf302de13268bbc4906fbde9c01e ChangeLog 6679
+MD5 d311e24bad645f1e02171305e415574c files/digest-wesnoth-0.9.1 139
MD5 3c7adc12b44a2b4b9d788c8f422ba401 files/digest-wesnoth-0.8.11 141
MD5 b7e6563ad1ede86d02ff1afcaa76e84e files/digest-wesnoth-0.8.10 141
MD5 7240f4ddb5c9ceeed466ab43a3d97caf files/digest-wesnoth-0.9.0 139
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.9.1 b/games-strategy/wesnoth/files/digest-wesnoth-0.9.1
new file mode 100644
index 000000000000..61beaa6ba33f
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.9.1
@@ -0,0 +1,2 @@
+MD5 667eabd30d9fd61505288be5d53c3d46 wesnoth-0.9.1.tar.gz 37234931
+MD5 f1dc97220d836a18c00d1e776ad1ac07 wesnoth-lite-0.9.1.tar.gz 20635541
diff --git a/games-strategy/wesnoth/wesnoth-0.9.1.ebuild b/games-strategy/wesnoth/wesnoth-0.9.1.ebuild
new file mode 100644
index 000000000000..d0310645cdb7
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.9.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.9.1.ebuild,v 1.1 2005/04/26 03:59:02 mr_bones_ Exp $
+
+inherit eutils flag-o-matic gcc games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="!lite? ( mirror://sourceforge/wesnoth/${P}.tar.gz )
+ lite? ( mirror://sourceforge/wesnoth/${PN}-lite-${PV}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="editor gnome kde lite nls server tools"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/freetype-2
+ media-libs/sdl-net
+ sys-libs/zlib
+ virtual/x11"
+
+src_unpack() {
+ if use lite ; then
+ unpack ${PN}-lite-${PV}.tar.gz
+ S=${WORKDIR}/${PN}-lite-${PV}
+ else
+ unpack ${P}.tar.gz
+ fi
+}
+
+src_compile() {
+ if use lite ; then
+ S=${WORKDIR}/${PN}-lite-${PV}
+ fi
+ cd "${S}"
+ filter-flags -ftracer -fomit-frame-pointer
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable server) \
+ $(use_enable server campaign-server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable nls) \
+ $(use_with gnome) \
+ $(use_with kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ if use lite ; then
+ S=${WORKDIR}/${PN}-lite-${PV}
+ fi
+ cd "${S}"
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/"{icons,applnk,applications} "${D}/usr/share/"
+ dodoc MANUAL changelog
+ prepgamesdirs
+}