summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-12-09 20:36:39 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-12-09 20:36:39 +0000
commit2b42e5c8c03b48d50cc5ec29a1191a9888667a2b (patch)
tree542285b0f6b172317354385da1b7c793d2ada77b /games-strategy
parentAdded ~mips to KEYWORDS, excluded patch 6640_* (diff)
downloadhistorical-2b42e5c8c03b48d50cc5ec29a1191a9888667a2b.tar.gz
historical-2b42e5c8c03b48d50cc5ec29a1191a9888667a2b.tar.bz2
historical-2b42e5c8c03b48d50cc5ec29a1191a9888667a2b.zip
Updated ebuild with proper dependencies and closing bug #114803.
Package-Manager: portage-2.0.53
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/smac/ChangeLog5
-rw-r--r--games-strategy/smac/Manifest14
-rw-r--r--games-strategy/smac/smac-6.0a.ebuild29
3 files changed, 25 insertions, 23 deletions
diff --git a/games-strategy/smac/ChangeLog b/games-strategy/smac/ChangeLog
index 36a5489b895d..6eeef1510f6a 100644
--- a/games-strategy/smac/ChangeLog
+++ b/games-strategy/smac/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/smac
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/smac/ChangeLog,v 1.3 2005/10/21 18:17:16 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/smac/ChangeLog,v 1.4 2005/12/09 20:36:39 wolf31o2 Exp $
+
+ 09 Dec 2005; Chris Gianelloni <wolf31o2@gentoo.org> smac-6.0a.ebuild:
+ Updated ebuild with proper dependencies and closing bug #114803.
21 Oct 2005; Chris Gianelloni <wolf31o2@gentoo.org> smac-6.0a.ebuild:
Added addition dir variable to games_make_wrapper for bug #109793.
diff --git a/games-strategy/smac/Manifest b/games-strategy/smac/Manifest
index 9ff11ac6a0bb..333003caf460 100644
--- a/games-strategy/smac/Manifest
+++ b/games-strategy/smac/Manifest
@@ -1,14 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 7eeabd61cfb513d8028e269395cbde48 ChangeLog 708
+MD5 a7edba2c342886d24a1b841d593577c6 ChangeLog 848
MD5 3b8cb21212b3ca49eb93ea8bc2b3ab8b files/digest-smac-6.0a 63
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 53a330226569b4d5c6821770090be5e9 smac-6.0a.ebuild 2567
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDl3E2gIKl8Uu19MoRAlPgAJ42y+hByWe5LHd64cZInkuUAuo1GgCfSIRP
-JvQgzIYyh1gdS7KWupJAvcM=
-=OPQz
------END PGP SIGNATURE-----
+MD5 3ba66b19413a890b3f07962b7c713e96 smac-6.0a.ebuild 2826
diff --git a/games-strategy/smac/smac-6.0a.ebuild b/games-strategy/smac/smac-6.0a.ebuild
index 18361795720b..e715af9130ea 100644
--- a/games-strategy/smac/smac-6.0a.ebuild
+++ b/games-strategy/smac/smac-6.0a.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/smac/smac-6.0a.ebuild,v 1.4 2005/12/07 23:30:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/smac/smac-6.0a.ebuild,v 1.5 2005/12/09 20:36:39 wolf31o2 Exp $
-inherit games eutils
+inherit eutils games
-DESCRIPTION="Sid Meier's Alpha Centauri"
+
+DESCRIPTION="Linux port of the popular strategy game from Firaxis"
HOMEPAGE="http://www.lokigames.com/products/smac/"
SRC_URI="mirror://lokigames/${PN}/${P}-x86.run"
@@ -17,7 +18,16 @@ RESTRICT="nostrip"
DEPEND="games-util/loki_patch"
RDEPEND="virtual/x11
sys-libs/glibc
- sys-libs/lib-compat-loki"
+ sys-libs/lib-compat-loki
+ media-libs/libsdl
+ media-libs/sdl-ttf
+ media-libs/sdl-mixer
+ media-libs/smpeg
+ media-libs/freetype
+ sys-libs/zlib"
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
pkg_setup() {
cdrom_get_cds Alien_Crossfire_Manual.pdf
@@ -25,14 +35,11 @@ pkg_setup() {
}
src_unpack() {
- mkdir -p ${S}/a ${S}/b
+ mkdir -p ${S}/a
cd ${S}/a
unpack_makeself ${P}-x86.run
}
-dir=${GAMES_PREFIX_OPT}/${PN}
-Ddir=${D}/${dir}
-
src_install() {
dodir ${dir}
einfo "Copying files... this may take a while..."
@@ -65,11 +72,13 @@ src_install() {
# we run touch on ${D} so as to make sure portage doesnt do any such thing
find ${Ddir} -exec touch '{}' \;
- insinto /usr/share/pixmaps
- newins ${CDROM_ROOT}/icon.xpm smac.xpm
+ newicon ${CDROM_ROOT}/icon.xpm smac.xpm
games_make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
games_make_wrapper ${PN}x ./${PN}x "${dir}" "${dir}"
+ make_desktop_entry smac "Sid Meier's Alpha Centauri" smac.xpm
+ make_desktop_entry smacx "Sid Meier's Alpha Centauri - Alien Crossfire" \
+ smac.xpm
prepgamesdirs
einfo "Linking libs provided by 'sys-libs/lib-compat-loki' to '${dir}'."