summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-08-31 20:29:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-08-31 20:29:58 +0000
commit2405bbbcb840ccceebff9c03510c93d3ccea96ee (patch)
treebe3cd52c72ec04d0126e48747d1d7e192cc274e5 /games-strategy/xscorch/xscorch-0.2.0-r1.ebuild
parentupstream patch reported by Heinz Striebeck via bug #104402 (diff)
downloadhistorical-2405bbbcb840ccceebff9c03510c93d3ccea96ee.tar.gz
historical-2405bbbcb840ccceebff9c03510c93d3ccea96ee.tar.bz2
historical-2405bbbcb840ccceebff9c03510c93d3ccea96ee.zip
rev bump to force out the latest patch; tidy old ebuilds
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'games-strategy/xscorch/xscorch-0.2.0-r1.ebuild')
-rw-r--r--games-strategy/xscorch/xscorch-0.2.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-strategy/xscorch/xscorch-0.2.0-r1.ebuild b/games-strategy/xscorch/xscorch-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..a3562589c743
--- /dev/null
+++ b/games-strategy/xscorch/xscorch-0.2.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xscorch/xscorch-0.2.0-r1.ebuild,v 1.1 2005/08/31 20:29:58 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="clone of the classic DOS game, 'Scorched Earth'"
+HOMEPAGE="http://xscorch.org"
+SRC_URI="http://xscorch.org./releases/${P}.tar.gz
+ http://xscorch.org/releases/${P}-stack-smash.patch.gz
+ http://xscorch.org./releases/${P}-64bit.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ppc x86"
+IUSE="gnome gtk mikmod"
+
+DEPEND="gtk? ( =x11-libs/gtk+-1* )
+ mikmod? ( media-libs/libmikmod )
+ gnome? ( gnome-base/gnome-libs )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ epatch \
+ "${DISTDIR}/${P}-64bit.patch.gz" \
+ "${DISTDIR}/${P}-stack-smash.patch.gz"
+}
+
+src_compile() {
+ #configure failed on readline support
+ egamesconf \
+ --enable-network \
+ --without-readline \
+ $(use_enable mikmod sound) \
+ $(use_with gtk) \
+ $(use_with gnome) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ # remove unneeded, empty directory
+ rmdir "${D}"/usr/games/include
+ prepgamesdirs
+}