summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-01-28 08:47:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-01-28 08:47:18 +0000
commitdf4b2dd2651c3b1f1da4fdf7e16c558c4a7b498c (patch)
tree3202a3bd9c4fbfbe857eb5f1cc376230d5c6a580 /games-strategy/triplea
parentVersion bump. (diff)
downloadhistorical-df4b2dd2651c3b1f1da4fdf7e16c558c4a7b498c.tar.gz
historical-df4b2dd2651c3b1f1da4fdf7e16c558c4a7b498c.tar.bz2
historical-df4b2dd2651c3b1f1da4fdf7e16c558c4a7b498c.zip
version bump
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'games-strategy/triplea')
-rw-r--r--games-strategy/triplea/ChangeLog8
-rw-r--r--games-strategy/triplea/files/digest-triplea-0.9.0.23
-rw-r--r--games-strategy/triplea/triplea-0.9.0.2.ebuild69
3 files changed, 79 insertions, 1 deletions
diff --git a/games-strategy/triplea/ChangeLog b/games-strategy/triplea/ChangeLog
index 45a0069a8e91..e958ccb144f0 100644
--- a/games-strategy/triplea/ChangeLog
+++ b/games-strategy/triplea/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/triplea
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/ChangeLog,v 1.26 2007/01/07 20:18:33 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/ChangeLog,v 1.27 2007/01/28 08:47:18 mr_bones_ Exp $
+
+*triplea-0.9.0.2 (28 Jan 2007)
+
+ 28 Jan 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +triplea-0.9.0.2.ebuild:
+ version bump
*triplea-0.9.0.1 (07 Jan 2007)
diff --git a/games-strategy/triplea/files/digest-triplea-0.9.0.2 b/games-strategy/triplea/files/digest-triplea-0.9.0.2
new file mode 100644
index 000000000000..0f31266f0b8f
--- /dev/null
+++ b/games-strategy/triplea/files/digest-triplea-0.9.0.2
@@ -0,0 +1,3 @@
+MD5 f96255fe0501c8201b565011e4fc2600 triplea_0_9_0_2_source_code_only.zip 13624383
+RMD160 f1ba831a92a593e0d0f8b34ac324e1f7ffeeea37 triplea_0_9_0_2_source_code_only.zip 13624383
+SHA256 1ce749cf7c107ebe7aaac13b91a31c30b453e8414a7935755be2857561e1bce7 triplea_0_9_0_2_source_code_only.zip 13624383
diff --git a/games-strategy/triplea/triplea-0.9.0.2.ebuild b/games-strategy/triplea/triplea-0.9.0.2.ebuild
new file mode 100644
index 000000000000..029338a527e4
--- /dev/null
+++ b/games-strategy/triplea/triplea-0.9.0.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/triplea-0.9.0.2.ebuild,v 1.1 2007/01/28 08:47:18 mr_bones_ Exp $
+
+inherit eutils java-ant-2 java-pkg-2 versionator games
+
+MY_PV=$(replace_all_version_separators _)
+DESCRIPTION="An open source clone of the popular Axis and Allies boardgame"
+HOMEPAGE="http://triplea.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${MY_PV}_source_code_only.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="=dev-java/jgoodies-looks-2*
+ =dev-java/commons-httpclient-3*
+ dev-java/commons-logging
+ dev-java/commons-codec"
+DEPEND="${RDEPEND}
+ >=virtual/jdk-1.5
+ dev-java/ant
+ app-arch/unzip"
+RDEPEND="${RDEPEND}
+ >=virtual/jre-1.5"
+
+S=${WORKDIR}/${PN}_${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e 's:/triplea/:/.triplea/:' \
+ src/games/strategy/engine/framework/ui/SaveGameFileChooser.java \
+ || die "sed failed"
+
+ rm -f lib/{junit.jar,derby_10_1_2.jar}
+ java-pkg_jar-from jgoodies-looks-2.0 looks.jar lib/looks-2.0.4.jar
+ java-pkg_jar-from commons-httpclient-3 commons-httpclient.jar \
+ lib/commons-httpclient-3.0.1.jar
+ java-pkg_jar-from commons-logging commons-logging.jar \
+ lib/commons-logging-1.1.jar
+ java-pkg_jar-from commons-codec commons-codec.jar \
+ lib/commons-codec-1.3.jar
+ java-pkg_ensure-no-bundled-jars
+}
+
+src_compile() {
+ eant || die
+ echo "triplea.saveGamesInHomeDir=true" > classes/triplea.properties
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r classes data games images maps || die "doins failed"
+
+ java-pkg_addcp "${GAMES_DATADIR}"/${PN}/classes
+ java-pkg_dolauncher ${PN} -into "${GAMES_PREFIX}" --main \
+ games.strategy.engine.framework.GameRunner
+
+ newicon icons/triplea_icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} TripleA /usr/share/pixmaps/${PN}.bmp
+
+ dodoc changelog.txt
+ dohtml -r doc/* readme.html
+ prepgamesdirs
+}