summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-06-03 12:01:07 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-06-03 12:01:07 +0000
commit474bf8927023cf9b345138f853c3b7b702b86c3a (patch)
tree94c0552ddff63ab6b9e647994a484b90e76a1a68 /games-sports
parentInitial import. Fixes #50005. (diff)
downloadhistorical-474bf8927023cf9b345138f853c3b7b702b86c3a.tar.gz
historical-474bf8927023cf9b345138f853c3b7b702b86c3a.tar.bz2
historical-474bf8927023cf9b345138f853c3b7b702b86c3a.zip
Added to patch to fix compile on non-nvidia hardware and closing bug #52600.
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/foobillard/ChangeLog6
-rw-r--r--games-sports/foobillard/Manifest7
-rw-r--r--games-sports/foobillard/files/foobillard-3.0a-no_nvidia.patch18
-rw-r--r--games-sports/foobillard/foobillard-3.0a.ebuild3
4 files changed, 29 insertions, 5 deletions
diff --git a/games-sports/foobillard/ChangeLog b/games-sports/foobillard/ChangeLog
index c60908b2365b..c04e617505e3 100644
--- a/games-sports/foobillard/ChangeLog
+++ b/games-sports/foobillard/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-sports/foobillard
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/ChangeLog,v 1.6 2004/06/02 07:33:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/ChangeLog,v 1.7 2004/06/03 12:01:07 wolf31o2 Exp $
+
+ 03 Jun 2004; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/foobillard-3.0a-no_nvidia.patch, foobillard-3.0a.ebuild:
+ Added to patch to fix compile on non-nvidia hardware and closing bug #52600.
02 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> foobillard-3.0a.ebuild:
Attempt to address bug #52600
diff --git a/games-sports/foobillard/Manifest b/games-sports/foobillard/Manifest
index 70b18b267d2d..2f64b39ba7ba 100644
--- a/games-sports/foobillard/Manifest
+++ b/games-sports/foobillard/Manifest
@@ -1,8 +1,9 @@
-MD5 d1e40acabfac541dc39110261a316f08 ChangeLog 1903
+MD5 fda5528311175fb56afc8f2ceb46223f foobillard-3.0a.ebuild 1223
MD5 49a1fe460078eade9e98a62a908e3a48 foobillard-2.8.ebuild 1128
+MD5 3b70eec2d19ed0ffabd6b0db148ebfe7 ChangeLog 2103
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 a1087a1c3190b4771a25cfede5dd551f foobillard-2.9.ebuild 1181
-MD5 531ed58148b3e05ec1a8ab22a3fa97c9 foobillard-3.0a.ebuild 1182
+MD5 11223d31662deec372e491cf27384d31 files/digest-foobillard-3.0a 68
+MD5 8eaf137a771395b81cfdbe6796fc612c files/foobillard-3.0a-no_nvidia.patch 770
MD5 7e9ec0cee63a42f327ed7d5de7127028 files/digest-foobillard-2.8 67
MD5 4827c3043c229b4ec77086d4554e7a7a files/digest-foobillard-2.9 67
-MD5 11223d31662deec372e491cf27384d31 files/digest-foobillard-3.0a 68
diff --git a/games-sports/foobillard/files/foobillard-3.0a-no_nvidia.patch b/games-sports/foobillard/files/foobillard-3.0a-no_nvidia.patch
new file mode 100644
index 000000000000..b43707bc403b
--- /dev/null
+++ b/games-sports/foobillard/files/foobillard-3.0a-no_nvidia.patch
@@ -0,0 +1,18 @@
+--- src/ball.c.orig 2004-06-02 07:00:57.000000000 -0400
++++ src/ball.c 2004-06-02 07:03:52.000000000 -0400
+@@ -1821,6 +1821,7 @@
+ } else if( options_cuberef && cuberef_binds!=0 ){
+ glBindTexture(GL_TEXTURE_CUBE_MAP_ARB, cuberef_binds[i]);
+ #ifdef GL_VERTEX_PROGRAM_NV
++#ifdef USE_BALL_FRESNEL
+ {
+ myvec cam_pos2;
+ // cam_pos2=vec_scale(vec_unit(vec_diff(cam_pos,balls.ball[i].r)),BALL_D/2.5);
+@@ -1829,6 +1830,7 @@
+ BALL_D/2.0,BALL_D/2.5,0,0 );
+ }
+ #endif
++#endif
+ draw_ball(&balls.ball[i],cam_pos,cam_FOV,win_width,0);
+ }else{
+ draw_ball(&balls.ball[i],cam_pos,cam_FOV,win_width,0);
diff --git a/games-sports/foobillard/foobillard-3.0a.ebuild b/games-sports/foobillard/foobillard-3.0a.ebuild
index b8f0ea8bc42a..3099f065a3d8 100644
--- a/games-sports/foobillard/foobillard-3.0a.ebuild
+++ b/games-sports/foobillard/foobillard-3.0a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-3.0a.ebuild,v 1.2 2004/06/02 07:33:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-3.0a.ebuild,v 1.3 2004/06/03 12:01:07 wolf31o2 Exp $
inherit games
@@ -25,6 +25,7 @@ DEPEND="virtual/x11
)"
src_compile() {
+ epatch ${FILESDIR}/${P}-no_nvidia.patch
local myconf=""
[ "$(ls /usr/include/GL/gl.h -al | awk '{print $NF}' | cut -d/ -f5)" == "nvidia" ] \
&& myconf="--enable-nvidia=yes" \