summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-01 22:09:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-01 22:09:55 +0000
commit10d5ec9d7710be0fb633df9c4d01782f3ac45d35 (patch)
tree9f8d04234ac832b59113d3dd7a55ff49ce45230c /games-simulation
parenttypo fix #46526 (diff)
downloadhistorical-10d5ec9d7710be0fb633df9c4d01782f3ac45d35.tar.gz
historical-10d5ec9d7710be0fb633df9c4d01782f3ac45d35.tar.bz2
historical-10d5ec9d7710be0fb633df9c4d01782f3ac45d35.zip
initial commit; ebuild submitted by Alexandru Toma via bug #46472
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/qct/ChangeLog10
-rw-r--r--games-simulation/qct/Manifest4
-rw-r--r--games-simulation/qct/files/digest-qct-0.71
-rw-r--r--games-simulation/qct/metadata.xml5
-rw-r--r--games-simulation/qct/qct-0.7.ebuild33
5 files changed, 53 insertions, 0 deletions
diff --git a/games-simulation/qct/ChangeLog b/games-simulation/qct/ChangeLog
new file mode 100644
index 000000000000..14160405ee0c
--- /dev/null
+++ b/games-simulation/qct/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-simulation/qct
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/ChangeLog,v 1.1 2004/04/01 22:09:55 mr_bones_ Exp $
+
+*qct-0.7 (01 Apr 2004)
+
+ 01 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> metadata.xml,
+ qct-0.7.ebuild:
+ initial commit; ebuild submitted by Alexandru Toma via bug #46472
+
diff --git a/games-simulation/qct/Manifest b/games-simulation/qct/Manifest
new file mode 100644
index 000000000000..1c6c878f7703
--- /dev/null
+++ b/games-simulation/qct/Manifest
@@ -0,0 +1,4 @@
+MD5 2576bb16bda3c649189dda4536ca5f77 qct-0.7.ebuild 790
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 53630ea21946a59abe66138e47b9bea2 ChangeLog 405
+MD5 987c0051916a2bfe70b434fcdaec006f files/digest-qct-0.7 58
diff --git a/games-simulation/qct/files/digest-qct-0.7 b/games-simulation/qct/files/digest-qct-0.7
new file mode 100644
index 000000000000..2b2ec7772505
--- /dev/null
+++ b/games-simulation/qct/files/digest-qct-0.7
@@ -0,0 +1 @@
+MD5 7af582f45d5d45c5917ead7d4bc574d0 qct-0.7.tar.gz 98126
diff --git a/games-simulation/qct/metadata.xml b/games-simulation/qct/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-simulation/qct/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-simulation/qct/qct-0.7.ebuild b/games-simulation/qct/qct-0.7.ebuild
new file mode 100644
index 000000000000..4a59046b0647
--- /dev/null
+++ b/games-simulation/qct/qct-0.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/qct-0.7.ebuild,v 1.1 2004/04/01 22:09:55 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Quiet Console Town puts you in the place of the mayor of a budding new console RPG city"
+HOMEPAGE="http://sourceforge.net/projects/qct/"
+SRC_URI="mirror://sourceforge/qct/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.2.1
+ >=dev-python/pygame-1.5.5"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ local destdir="${GAMES_DATADIR}/${PN}"
+ insinto "${destdir}"
+ exeinto "${destdir}"
+
+ dodoc README
+ doins *.py *.png
+ doexe qct.py
+
+ games_make_wrapper qct "./qct.py" "${destdir}"
+
+ prepgamesdirs
+}