summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2007-10-01 23:56:44 +0000
committerLars Weiler <pylon@gentoo.org>2007-10-01 23:56:44 +0000
commite61efaa8d1a9c8648dc04c82010f92a06a99c440 (patch)
tree3a7ba2466977e20cc61bb89e47d7aa6643af6a11 /games-simulation/openttd
parentold (diff)
downloadhistorical-e61efaa8d1a9c8648dc04c82010f92a06a99c440.tar.gz
historical-e61efaa8d1a9c8648dc04c82010f92a06a99c440.tar.bz2
historical-e61efaa8d1a9c8648dc04c82010f92a06a99c440.zip
Fixed quoting issues and changed configure-call.
Package-Manager: portage-2.1.3.11
Diffstat (limited to 'games-simulation/openttd')
-rw-r--r--games-simulation/openttd/Manifest14
-rw-r--r--games-simulation/openttd/openttd-0.5.3.ebuild22
2 files changed, 18 insertions, 18 deletions
diff --git a/games-simulation/openttd/Manifest b/games-simulation/openttd/Manifest
index af30d4e53a8b..393bf22db062 100644
--- a/games-simulation/openttd/Manifest
+++ b/games-simulation/openttd/Manifest
@@ -14,10 +14,10 @@ EBUILD openttd-0.5.2.ebuild 5658 RMD160 444180c147f90e8d8ecf1cdf8f9a70e7a99c0e8e
MD5 8b3608c29a9a191aa9bd02cb44842e95 openttd-0.5.2.ebuild 5658
RMD160 444180c147f90e8d8ecf1cdf8f9a70e7a99c0e8e openttd-0.5.2.ebuild 5658
SHA256 544abcbf419c5f08e7e673c787d4cc76c3f28aec31194415611f9941545a324b openttd-0.5.2.ebuild 5658
-EBUILD openttd-0.5.3.ebuild 5991 RMD160 8a734de152316d3c5271702d89754c6af0edc8e4 SHA1 2f5c2749e76ab71f04f2f37d879f779a64d9bc40 SHA256 316fe213a10ff574a223aa3686695a6458a33e995a191e1ab7bb921b2a35f116
-MD5 a83124c355f37dbf9eec137a37e56f81 openttd-0.5.3.ebuild 5991
-RMD160 8a734de152316d3c5271702d89754c6af0edc8e4 openttd-0.5.3.ebuild 5991
-SHA256 316fe213a10ff574a223aa3686695a6458a33e995a191e1ab7bb921b2a35f116 openttd-0.5.3.ebuild 5991
+EBUILD openttd-0.5.3.ebuild 5909 RMD160 9d5d8aab01123291435d97cca6849385c0bd37b9 SHA1 69aa7828a7ccea1f91fb0380868a5a009335f443 SHA256 c886f35df15e3e2c8eebce8853094a22d2887cb20d16da120ad5cb6db48875b1
+MD5 6e33e8355ac3f1eba2c48968001d944a openttd-0.5.3.ebuild 5909
+RMD160 9d5d8aab01123291435d97cca6849385c0bd37b9 openttd-0.5.3.ebuild 5909
+SHA256 c886f35df15e3e2c8eebce8853094a22d2887cb20d16da120ad5cb6db48875b1 openttd-0.5.3.ebuild 5909
EBUILD openttd-0.5.3_rc3.ebuild 5910 RMD160 1c9e9bdf47cee85a3e9ba71e3b7c98609adde4d5 SHA1 13dd9c0a3ddec28b8d0c2f0be924d14d9d7e410c SHA256 5903be50854bc3b915a8b620931aa9c325be1d7e434cfc0e85d13cd5ca26aabe
MD5 bd6f3ca80ab02f23da1ef0976051c315 openttd-0.5.3_rc3.ebuild 5910
RMD160 1c9e9bdf47cee85a3e9ba71e3b7c98609adde4d5 openttd-0.5.3_rc3.ebuild 5910
@@ -42,7 +42,7 @@ SHA256 6d45ab5911ceaba1ab102b013d3f67a2940fa610791f893b9328d2771fc56b3a files/di
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)
-iD8DBQFHAOQd6IPkARlRZfQRAqHtAKCRLz/K5PSUnpCgkAHLQhBv83vg4wCfXOeK
-atgv1ypkSwvrbMpaSe8rGBg=
-=ntbT
+iD8DBQFHAYlW6IPkARlRZfQRAoZsAJ9qFJ7fPuErPJEE/Ckd3evsRP7QtwCff9IF
+Elt3Ghz0v+rAMXBjJ7UVROs=
+=EdCk
-----END PGP SIGNATURE-----
diff --git a/games-simulation/openttd/openttd-0.5.3.ebuild b/games-simulation/openttd/openttd-0.5.3.ebuild
index b4b6067e514f..891b8b24efd4 100644
--- a/games-simulation/openttd/openttd-0.5.3.ebuild
+++ b/games-simulation/openttd/openttd-0.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.5.3.ebuild,v 1.1 2007/10/01 12:11:46 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.5.3.ebuild,v 1.2 2007/10/01 23:56:44 pylon Exp $
inherit eutils games
@@ -45,11 +45,11 @@ pkg_setup() {
src_unpack() {
unpack ${MY_P}-source.tar.bz2
if use scenarios ; then
- cd ${S}/scenario/
+ cd "${S}"/scenario/
unpack ${SCENARIOS_048}
unpack ${SCENARIOS_050}
fi
- cd ${S}
+ cd "${S}"
# Don't pre-strip binaries (bug #137822)
sed -i -e '/+= -s$/s/-s//' Makefile || die "sed failed"
# Don't install into prefixed DATA_DIR
@@ -61,11 +61,7 @@ src_unpack() {
src_compile() {
local myopts=""
use debug && myopts="${myopts} --debug"
- use static && myopts="${myopts} --with-static"
use dedicated && myopts="${myopts} --dedicated --without-sdl"
- use iconv && myopts="${myopts} --with-iconv"
- use png && myopts="${myopts} --with-png"
- use zlib && myopts="${myopts} --with-zlib"
if ! use dedicated; then
myopts="${myopts} --with-sdl --with-freetype --with-fontconfig"
if ! use timidity; then
@@ -76,6 +72,10 @@ src_compile() {
# configure is a hand-written sh-script, so econf will not work
./configure --os=UNIX \
--with-network \
+ $(use_with static) \
+ $(use_with iconv) \
+ $(use_with png) \
+ $(use_with zlib) \
${myopts} \
|| die "configure failed"
@@ -83,11 +83,11 @@ src_compile() {
MANUAL_CONFIG=1 \
INSTALL=1 \
USE_HOMEDIR=1 \
- DEST_DIR=${D} \
+ DEST_DIR="${D}" \
PERSONAL_DIR=.openttd \
- PREFIX=${GAMES_PREFIX} \
- DATA_DIR=${GAMES_DATADIR}/${PN} \
- CUSTOM_LANG_DIR=${GAMES_DATADIR}/${PN}/lang \
+ PREFIX="${GAMES_PREFIX}" \
+ DATA_DIR="${GAMES_DATADIR}"/${PN} \
+ CUSTOM_LANG_DIR="${GAMES_DATADIR}"/${PN}/lang \
|| die "emake failed"
}